⚠️ Forum Maintenance: Feb 6th, 8am - 14pm (UTC+2)

[SOLVED] Problems with actions in menuBar

  • hey guys! I'm trying to create an action in menu bar (mainwindow), but when i compile the application, the action is not shown in menu bar. i've already made a clean build without success... What can i do?

  • Moderators

    Some code would be useful

  • I'm using Qt Form Designer

  • MenuBar do not shows the changes that i try to make using Qt Form Designer.

  • Moderators

    Clearly the designer works in general, so could you give a little more detail? OS, version of creator and Qt for starters. What steps are you taking, what have you tried etc.
    Do any other changes to the widgets are applied? Like if you added a button somewhere? What if you added an action to the bar from code, does that get applied?

  • OS: Ubuntu 12.04 32bits
    QtCreator: 2.4.1
    Qt: 4.8.0
    Steps: In menu Bar, i have a File menu. I create a new submenu clicking on "type here" then i execute the application (ctrl+r).

    If i add an button in mainWindow, do not works too. I do not tried to create by code, i will test this later.

  • Moderators

    Things you can try:

    • right click on the project and select "run qmake"
    • delete the output folder entirely and try to build again

  • Still not working :(

  • SOLVED! I just uncheck "shadow build" in the "Projects" label, compile, and then check and compile again.

  • Moderators

    What do you mean by not working? Not building? Not starting? Showing empty widget? Showing mainwindow with empty bars? Please try to be more specyfic and provide as much info as possible. At this pace we're not getting anywhere anytime soon ;)

    If you deleted the output directory, rebuilt and your program run, then something did build and run but it's not your project.
    If it's not your project then you have some serious configuration issue. Remove the output again, remove the .user file, re-open the project to re-configure the kit and see what happens.

    EDIT: ok, I'm glad you figured it out

Log in to reply