[SOLVED] Strange Access violation after breakpoint



  • i'm using Qt and already wrote some app, but later i have changed some part of it, set bp in interesting to me places and catch an access violation.

    I've tried use qt 4.8 or qt 5 from public installer, build stable version from git, build betta version, reinstall MSVC and Windows, but always same - i can run my newly builded app or older version and it's works fine, all other my apps also, but when i set a bp in app which uses QT and continue or step after it i'm catching exception, even in test project created by QT Add-in automaticaly.

    In all cases the address where AV happened is different, but always this address range is not using by anyone.

    I realy confused.

    I faced before with this, but it was caused by heap corruption. But in default qt project it's nearly impossible.

    SOLUTION:
    Turn Off RPC Debugging in MSVC->Debugging->Options


  • Moderators

    Which IDE and/or debugger do you use? Which OS?



  • Windows 7x64 sp1 eng, Visual studio 2010 sp1



  • I'm having the same problems. After setting a breakpoint and pressing "F10" after the program has stopped at the breakpoint, an access violation occurs and I cannot continue with debugging. If I pause the program by pressing the pause button, debugging works. I'm using Qt 5.1 beta, msvc2012 amd64 compiler and QtCreator 2.8.0-beta.


  • Moderators

    Could you "please file a bug report":https://bugreports.qt-project.org/ then and attach the debugger log to it? Thanks!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.