[SOLVED]Problem with Qt last version.



  • Hello, guys. I have Qt Creator last version with Gcc-4.7, G++4.7 and Cmake-2.8.9 in my Debian Squeeze 6.0.7. I'm trying to install a program called Avogadro but i'm having the bellow error message:
    [quote]-- The build type is Release
    CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:97 (MESSAGE):
    Could NOT find Qt4 (missing: QT_QMAKE_EXECUTABLE QT_MOC_EXECUTABLE
    QT_RCC_EXECUTABLE QT_UIC_EXECUTABLE QT_INCLUDE_DIR QT_LIBRARY_DIR
    QT_QTCORE_LIBRARY) (Required is at least version "4.6.0")
    Call Stack (most recent call first):
    /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:288 (_FPHSA_FAILURE_MESSAGE)
    /usr/share/cmake-2.8/Modules/FindQt4.cmake:1200 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
    CMakeLists.txt:226 (find_package)

    -- Configuring incomplete, errors occurred![/quote]

    This software requires Qt 4.5.0 or later (4.5.3 recommended), but i have the last version! How can i solve this problem?



  • Hi,

    this question isn't related directly to Qt but to CMake.
    However you shall ensure that Qt installation binari directory (where there is qmake executable) is in your PATH environment variable before launch CMake


  • Moderators

    Setting QTDIR might also help, although Qt Creator should take care of both PATH and QTDIR.



  • Really sorry, guys. First and last time i create a topic which is not related directly to Qt.
    I created a link in /usr/bin/ for /opt/Qt5.0.2/5.0.2/gcc_64/bin/qmake, so i have this /usr/bin/qmake.
    But now, this error message appears.
    [quote]-- The build type is Release
    CMake Warning at /usr/share/cmake-2.8/Modules/FindQt4.cmake:604 (MESSAGE):
    /usr/bin/qmake reported QT_INSTALL_LIBS as "/opt/Qt5.0.2/5.0.2/gcc_64/lib"
    but QtCore could not be found there. Qt is NOT installed correctly for the
    target build environment.
    Call Stack (most recent call first):
    CMakeLists.txt:226 (find_package)

    CMake Error at /usr/share/cmake-2.8/Modules/FindQt4.cmake:608 (MESSAGE):
    Could NOT find QtCore. Check
    /opt/avogadro-1.1.0/build/CMakeFiles/CMakeError.log for more details.
    Call Stack (most recent call first):
    CMakeLists.txt:226 (find_package)

    -- Configuring incomplete, errors occurred!
    [/quote]
    I really don't know how to edit my PATH environment variable, i don't even know where she is!
    By the way Qt is working perfectly.



  • In a terminal, you can set the variables using the export command, as shown in these lines:

    export QTDIR="/path/to/qt-5.0.1"
    export PATH="${QTDIR}/bin:${PATH}"

    There's this variable which might be usefull when working with cmake:

    export CMAKE_PREFIX_PATH="${QTDIR}"

    It adds the path to Qt to Cmake's search path.



  • [quote author="Guigui" date="1369751663"]In a terminal,



  • [quote author="Guigui" date="1369751663"]In a terminal, you can set the variables using the export command, as shown in these lines:

    export QTDIR="/path/to/qt-5.0.1"
    export PATH="${QTDIR}/bin:${PATH}"

    There's this variable which might be usefull when working with cmake:

    export CMAKE_PREFIX_PATH="${QTDIR}"

    It adds the path to Qt to Cmake's search path.[/quote]

    Hi, i edited the /etc/profile file. I added the following lines:
    [quote]export QTDIR=/opt/Qt5.0.2/
    export PATH=${QTDIR}/bin:${PATH}
    export CMAKE_PREFIX_PATH=${QTDIR}[/quote]
    I'm having the same error message.
    I tried to set this variables in terminal to, but didn't work.



  • Hi,

    If your application is designed for Qt4.5, then it can not work with Qt5. But you can use Qt4.6/Qt4.7/Qt4.8



  • [quote author="1+1=2" date="1369892073"]Hi,

    If your application is designed for Qt4.5, then it can not work with Qt5. But you can use Qt4.6/Qt4.7/Qt4.8[/quote]

    Ok, i installed qt4 and now everything is working fine. Thanks a lot.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.