Please nominate your Qt Champions for 2021!

[SOLVED] QMake gives dirty env vars to XCode.

  • OS X 10.8

    While setting up a Qt 5.1 Beta iOS project, I moved QTDIR and Creator got infuriated at me. It didn't calm down until I restarted OS X, and now XCode is complaining about similar things as Creator had. It remembers the old location and tries to do relative paths from it, and that doesn't work. It's somehow setting dirty values for several env vars in "PhaseScriptExecution," per the build output from XCode:


    I tried deleting the generated files in my build directory (except Info.plist, as I'm not as sure what generates that one) and the problem persisted. Help, please?

  • Moderators

    Paths are hardcoded into Qt libraries. Do not move installed Qt around. Delete and recompile at new location, or you can use qt.conf file to override the paths.

  • The moved build was not the one I was building with; I was actually seeing this with two SDK installations which were not the original troublemaker. I deleted the troublemaker anyway just to make sure, and installed a new copy for its purpose (Mac desktop). Is there anything else that might be remembering this?

  • I provisionally used a symlink to trick XCode past that error, and now I seem to have a more sensible one: <sysroot>/plugins/platforms/libqios_debug.a is not found, however I see that libqios.a is there. Could someone be building for release and another expecting debug? Creator is certainly set to debug, and I'm not sure anyone else is involved.

  • Ah, that was stupid of me. I had deleted the old QTDIR and forgotten that I was still running the Creator from within it. In the future I'll try to not mess with Qt's stuff, but I downloaded a standalone Creator so it wouldn't hurt quite so bad if I did. <.<

    And it still won't compile... Gah! New issue, new thread.

Log in to reply