Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QT Creator 2.4.1 - QT 4.7.4With GCC 4.8.0?



  • Hi,

    I installed in my mac the gcc 4.8.0.
    The default folder is the /opt/gcc-4.8.0/
    So i changed my path to load the gcc-4.8.0 first.
    Now if i do the gcc -v it returns the 4.8.0 and no the 4.2.1.
    But, if i compile using the QT Creator it uses the 4.2.1.
    How i know?
    I added a -v option.
    In the Compile Output:

    @Using built-in specs.
    Target: i686-apple-darwin11
    Configured with: /private/var/tmp/llvmgcc42/llvmgcc42-2335.15~25/src/configure --disable-checking --enable-werror --prefix=/Developer/usr/llvm-gcc-4.2 --mandir=/share/man --enable-languages=c,objc,c++,obj-c++ --program-prefix=llvm- --program-transform-name=/^[cg][^.-]*$/s/$/-4.2/ --with-slibdir=/usr/lib --build=i686-apple-darwin11 --enable-llvm=/private/var/tmp/llvmgcc42/llvmgcc42-2335.15~25/dst-llvmCore/Developer/usr/local --program-prefix=i686-apple-darwin11- --host=x86_64-apple-darwin11 --target=i686-apple-darwin11 --with-gxx-include-dir=/usr/include/c++/4.2.1
    Thread model: posix
    gcc version 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00)@

    How i force the QT to use the GCC in the new place, i tried to create a new tool chain (Manual)
    But no luck.
    It seems to be a simple thing to do but i tried a lot of thing just to dev using C++11.

    How can i do that?

    Regards


  • Moderators

    Stick with 4.2.1, Gcc 4.8.0 will not work with Qt Creator 2.4 anyway: The format of error messages has changed and thus you will not get build issues anymore.


Log in to reply