Need qt-mt 3.3.0 >= < 4.0 for Mac OS X 10.8.2 Mountain Lion



  • I need the package qt-mt.pc so I can build Twinkle SIP client for Mac OS X. This is the last lib issue I haven't solved yet to build this package.

    I have tried building from source qt-mac-free-3.3.8.tar.gz, but it says it doesn't support my version of mac. First, is the package qt-mt.pc in this version, if not which one do I need to build so I can get the wright libs and includes. If this the right version that will include this, is there any work around to build this on my OS? Software OS X 10.8.3 (12D78)

    Here is my message for the configure file from twinkle
    @checking for qt-mt >= 3.3.0 qt-mt < 4.0... Package qt-mt was not found in the pkg-config search path. Perhaps you should add the directory containing qt-mt.pc' to the PKG_CONFIG_PATH environment variable No package 'qt-mt' found Package qt-mt was not found in the pkg-config search path. Perhaps you should add the directory containingqt-mt.pc' to the PKG_CONFIG_PATH environment variable No package 'qt-mt' found
    configure: error: Library requirements (qt-mt >= 3.3.0 qt-mt < 4.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.@

    Further I looked into homebrew and only found version 4.8.4 which is too new.

    If I can get this all working, I had planned on adding Twinkle to home brew repository which depends on QT-MT

    Thanks in advance for any help offered here.


  • Moderators

    I don't think anyone maintains Qt3 - definitely it's not maintained officially, and I have not heard of unofficial support either.

    And no surprise - Qt3 is more or less dead for almost 8 years now!



  • Yes, thanks :) This is probably one of the reasons twinkle isn't in the brew repo :(


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.