Important: Please read the Qt Code of Conduct -

Using qmake built from buildroot with QtCreator

  • Hello,

    I am compiling Qt for my embedded application with buildroot. It is working fine for my embedded device, so no problems there. For developing, I would cross compile Qt in my machine and install it, then reference qmake's location within QtCreator. It does work fine.

    The thing is, I would like to use buildroot's compilation to develop with QtCreator, not another cross compilation done by me. I have other developers as well, and don't believe each having a particular compilation for Qt (qmake and libs), and yet another one for the embedded device is a good thing.

    With this in mind, I tried using buildroot's Qt compilation.

    However, the qmake I find within buildroot is not at the install location, nor are the include files and everything else, only the libs. I did copy over what I thought were the necessary files (include dir, bin dir, lib dir, etc) I found at another location in buildroot, however QtCreator says "Qt is not properly installed, please run make install".

    I already tried all sorts of "hacks" (like running make then make install in buildroot/output/build/qt and copying everything over), however nothing seemed to work.

    Could anyone clarify to me how I can use just one cross compilation to develop my application?

    Thanks in advance,


  • Hi

    I am using sabrelite imx6.
    I am investigating buildroot’s compilation to develop with QtCreator.
    I need to run several video stream on linario (imx6 freescale)

    Please kindly assist

  • Hello,

    It's been a while, and I completely forgot about this post. The problem before was that two different compilations of Qt were needed, one for deployment (compiled from buildroot) and another for development. Right now, each developer still needs to compile Qt, but its configuration comes from buildroot, which is under source control.

    Actually, all that was needed to do was to use qmake created from buildroot, which is located at $BUILDROOT_PATH/output/host/usr/bin/qmake. You can configure that at Tools -> Options -> Build & Run -> Qt Versions. You also need to specify the right compiler at the Kits tab.

    This doesn't change much, since each developer must compile Qt, but at least it only needs to be done once.

    Oh well, hope this helps.


  • Hi

    I am using imx 6 on sabrelite running on linaro. I can't locate qmake in $Buildroot_Path/output/host/usr/bin.

    The problem here is two different compilation are needed. One for development(qmake) and another for deployment(make for buildroot). Userland packages (after codes compilation) is then integrated into Root File System image before deployment manually. can i configure everything in one compilation?

    I am following below link.

  • It is odd you can't find qmake from within buildroot's compilation... You are compiling Qt with buildroot like that tutorial said, right? I mean, those userland packages you mentioned are compiled with buildroot or are they compiled manually and then copied along?

    Other than that, under $BUILDROOT_PATH/output, what is the output of find -name qmake?

  • I have problem using qmake to cross-compile in qtcreator. Do you have a sample qmake config.
    I sudo get-app install qmake. I am using this qmake not the one created by buildroot.

    How to compile the userlandin buildroot? pls advice. My intention is to copy manually.

    I try following the above links but i can't find the exact "support for framebuffer device"

Log in to reply