QtCreator 2.7.0 not finding Perforce



  • In QtCreator 2.7.0: Perforce plugin has the green-check. Under Tools->Options, I filled in the Perforce Configuration and Variable fields. The test succeeds and shows the correct path. I've restarted QtCreator several times.

    Still, QtCreator shows no recognition of Perforce. Create a QTQuick 2 App..."Add to Version control:" shows <None> only.
    I've never seen any Version-control-related menu items in QtCreator.

    Is this a bug? or am I missing a setting somewhere?


  • Moderators

    welcome to devnet

    You need to activate the Perforce plugin.
    The plugins are a bit hidden under "Help">>"About Plugins..." at the end of the list you find the different version control plugins.



  • What do you mean "activate"? Perforce plug-in already has the green-check and its "Load" box is checked. The plug-in dialog has no other actions available.


  • Moderators

    You can unfortunately not add new projects to perforce repositories from inside Qt Creator. That is why the "Add to version control" box will never list it.

    Once you open a perforce-controlled project that will work properly.

    With most other version control systems you can also import projects directly from a repository via Files>New Project>Import Project>Whatever Checkout, but unfortunately that is not supported for perforce either.



  • Okay, that begs the next question: I have projects already IN perforce, but since when they are loaded in QtCreator there are still no Perforce menu items, that must mean there is a step to make such a project "perforce-controlled".

    How does one make one's QtCreator project "perforce-controlled"?


  • Moderators

    I have to admit that it has been a long time since I last tried that, but there were no changes in the perforce code and no bug reports that it does not work anymore. Looking at the bug reports we seem to have hardly any users of perforce (or super stable integration with all features people might want;).

    Anyway: You create a project, open a terminal, do whatever you need to do to add files to perforce (sorry, don't know the actual commands on top of my head) and then open the project again in creator. Then perforce actions should become available.



  • Postscript: The project and files were in Perforce from the get-go...and still are.
    In QtCreator tools: the Perforce "test" has passed from the get-go...and still does.
    QtCreator 2.7.0 still shows no menu items nor any other sign that Perforce exists.

    So, since there's not a lot of time to play with QtCreator, I just do all my project work in MSVC 2010, and only use QtCreator to edit the QML code.


  • Moderators

    Would you mind "filing a bug report":https://bugreports.qt-project.org/ then so that the issue is properly tracked?



  • Bug report is filed.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.