Nominate our 2022 Qt Champions!

Help files unavailable in Qt Creator 2.6.1 (Mac OS X 10.6.8 intel-x86)

  • Any time I try to invoke the Help feature in Qt Creator, I get a "No documentation found" message. So I went to Preferences > Help > Documentation and noticed that there aren't any documentation files registered. If I attempt to manually register one by navigating to the correct qhc directory, then adding qt.qhc, it throws an error:

    bq. Unable to register documentation. Invalid documentation file: /opt/local/share/doc/qt4/qch/qt.qch

    I installed Qt 4.8 via MacPorts, so I am not sure if this would make any difference. I tried installing Qt 4.8 via source from but my build fails every time, so I have only been able to build via MacPorts.

  • This is a total shot in the dark (i.e. I don't know what I'm talking about, but putting it out there just in case it helps), but have you tried simply navigating to the docs directory instead of adding an actual .qch?

  • It turned out that I needed to install the sqlite3 plugin for Qt. Once I installed this via MacPorts, I was able to view the offline documentation successfully.

Log in to reply