[SOLVED] CMake kit does not exist for QT 5.0.2

  • I am a qt newbie and am trying to make a simple c++ project.
    I have downloaded qt installer version 5.0.2 with libraries and creator.

    After following the following steps:
    New Project - Plain C++ project(CMake build) - Introduction and Project location(I enter the name and the location)->click on Next- Click on Finish, the cmake wizard appears saying QTCreator has no kits that are suitable for CMake projects

    I press "Show Options" in the wizard
    I have the following kit automatically detected in the "Kits" tab:
    Desktop QT 5.0.2 MSVC2012 64bit(Default)

    If i go to the "CMake" tab i had no value entered but i entered:

    At the compiler section i have automatically detected:
    Microsoft Visual C++ Compiler 11.0 (x86)
    Microsoft Visual C++ Compiler 11.0 (amd64)

    Back to the "Kits" tab if i press "Desktop QT 5.0.2 MSVC2012 64bit(Default)"
    i have seed that it is using the amd64 compiler but i cannot change it

    I have set the paths for the CMake(and the compiler) in the PATH environment variable:
    C:\Qt\Qt5.0.2\5.0.2\msvc2012_64\bin - for cmake
    C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC - for compiler

    Still no luck. The CMake wizard still appears.
    Please help.

  • Have you CMake installed?

    "CMake":http://www.cmake.org/ is not qmake !!!

    If you just want do build an Plain C++ Projekt: use the Projekttype (without CMake Build!) in QTCreator

  • You are correct, i did not know that CMake was a separate product. Thank you very much.
    The project now works fine.

  • Please Mark the Post as resolved, by editing the Subject and put [SOLVED] in front

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.