Problem with QtWebkit installation after building Qt5 on windows with win32-msvc2012



  • Hello,

    I am trying to build Qt5 on windows using win32-msvc2102. The build seems to be going OK but when I try to run the youtubeview example I get the error:

    qrc:///youtubeview.qml:42:1: module "QtWebKit" is not installed

    I followed the forum instructions and tried to add QML2_IMPORT_PATH to ...\qtbase\imports where I found the QtWebkit binaries. After this I get the error:

    qrc:///youtubeview.qml:42:1: plugin cannot be loaded for module "QtWebKit": Unknown error

    I get the same result if I try to copy the QtWebkit directory from under qtbase\imports to qtbase\qml. There seems to be a bug on a similar problem reported earlier but windows isn't included in the platforms:
    https://bugreports.qt-project.org/browse/QTBUG-28308?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

    Is there something more I could try to fix this and get the example running? I also tried to add the webkit widgets
    (QT += quick qml webkit webkitwidgets) to youtubeview.pro but it doesn't help.

    Any help is appreciated! Thanks!



  • Anyone? On Linux Qt5 build the webkit module work without any problem and I got the youtubeview and flickr examples running.



  • Same problem for me, haven't found a workaround yet I'm on OSX 10.8. It happens with both the Alpha download and a fresh checkout of the stable tree from gitorious.



  • did you folks built it with openGL desktop option? what qt version btw? i had the same problem and its more likely that QtWebKit currently don't work with openGL desktop, find here https://bugreports.qt-project.org/browse/QTBUG-30963 and https://bugreports.qt-project.org/browse/QTBUG-30290



  • Thanks for the reply. I hope they fix this soon. I used the desktop option because using the other options I got some other errors... The webkit test runs OK and I am able to use the browser in the test but I think it's the qmlmodules that have this unknown error.



  • I updated QtWebkit submodule to its latest stable version in order to include the bugfix for https://bugreports.qt-project.org/browse/QTBUG-30290 and now the 'unknown error' is gone but youtubeview and flickerview examples are having problems starting up. With flickerview I get different errors on starting QtWebProcess.exe:

    Failed to start " "QtWebProcess.exe" 472"
    Failed to start " "QtWebProcess.exe" 416"
    Failed to start " "QtWebProcess.exe" 492"
    Failed to start " "QtWebProcess.exe" 472"

    And with youtubeview:

    Failed to start " "QtWebProcess.exe" 484"
    UIProcess\Launcher\qt\ProcessLauncherQt.cpp(187) : WebKit::ProcessLauncher::launchProcess
    The program has unexpectedly finished.

    Failed to start " "QtWebProcess.exe" 476"
    UIProcess\Launcher\qt\ProcessLauncherQt.cpp(187) : WebKit::ProcessLauncher::launchProcess
    The program has unexpectedly finished.



  • Now I got flickrview and youtubeview working with QtWebProcess once I added the ...\qtwebkit\bin to PATH variable.

    Still getting this with youtubeview but might be something with my setup, not sure...:

    Something went wrong, received HTTP status code 0



  • i built again with the latter update include QTBUG-30290 fix, but i still got the "unknown error", did you built it with angle or opengl -Desktop anyway?



  • I built it with this configuration:

    configure -debug-and-release -opensource -nomake examples -nomake tests -opengl desktop

    Did you do a pull on the qtwebkit module or just included the changes? I did the pull.



  • here is my configuration:
    @configure -developer-build -opensource -nomake examples -nomake tests -opengl desktop -make-tool jom -mp -confirm-license -openssl -openssl-linked -I C:\OpenSSL-Win64\include -L C:\OpenSSL-Win64\lib\VC\static -icu -I C:\icu\include -L C:\icu\lib64 -L C:\OpenSSL-Win64\lib
    @

    a painful configuration, and i still getting along with my configuration experiments, now i'm trying vs2012 and yet still compling



  • these are my issues

    • qmlwebkitplugin.dll is located at C:<QTDIR>\qtbase\imports\QtWebkit, this directory is belong to QML1. When i tested with a very simple qmlapp --

    @import QtQuick 1.1
    import QtWebKit 1.0@

    show message : loadPlugin failed on "C:/Qt/qt5/qtbase/imports/QtWebKit/qmlwebkitplugind.dll" : "Cannot load library C:/Qt/qt5/qtbase/imports/QtWebKit/qmlwebkitplugind.dll: "
    file:///C:/Users/ponkster/Documents/Qt/build-quick1test-Desktop-Debug/qml/quick1test/main.qml:2:1: plugin cannot be loaded for module "QtWebKit": Cannot load library C:/Qt/qt5/qtbase/imports/QtWebKit/qmlwebkitplugind.dll:
    import QtWebKit 1.0

    • there is no QtWebKit directory within QML2 imports directory which is located at C:<QTDIR>\qtbase\qml and then i copy QtWebkit from imports directory to qml directory and make a simple test
      @import QtQuick 2.0
      import QtWebKit 3.0@

    but it raised the same error message



  • I got it. I copied qmlwebkitplugin libraries from qtwebkit/imports directory into qtbase/qml dir, then I copied qmldir file from qtbase/imports/QtWebKit dir into qtbase/qml dir then i picked flickrview.pro from qtwebkit-examples. If I build with debug mode it will raise cannot load library error, but it will run in release mode though it didn't run smoothly, cause the flickr imageviewer just didn't appear and i got this message
    QOpenGLShader::link: "Vertex shader(s) linked, fragment shader(s) linked., but i think its not error message.



  • Did you try to set the QML2_IMPORT_PATH to point to qtbase/imports?



  • i haven't try it yet.,but it worth to try. can you give me complete configure example with QML2_IMPORT_PATH?



  • ok now i got it, QML2_IMPORT_PATH is environment variable


  • Moderators

    Good thread guys, thanks. Apparently, those bugs are still present in Qt 5.3.1 on Linux :-( but your solution helped me in getting it to work.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.