Important: Please read the Qt Code of Conduct -

Qt5 application will not run - no code in it just a Gui app created by the wizard - no error messages, no window, no nothing

  • So a colleague could play around with my app I gave him a copy of the exe and relevant Qt dll's. He clicks on it and the application does nothing whatsoever, no window, no nothing. I created an empty project and tried the same with the exe produced - adding no code at all. Just a Gui created by the QtCreator wizard. The exe (with the Qt dll's) my collegue is trying to run is on a network drive. I can run the application over the network.

    • We did exactly the same thing with an exe last year while I was still developing on Qt 4, everyone could run the exe over the network
    • if the Qt dll's are not in the same network directory as the exe missing dll errors occur for both myself and my colleague. Once all the correct dll's are in the exe directory the errors go away for me and the exe runs but for my colleague, once the error messages are all sorted nothing happens when he clicks on the exe
    • my colleague is not a developer so does not have Qt installed
    • if the exe and dll's are on my colleagues local machine he gets the same behaviour i.e. nothing
    • several other non development machines produce the same result

    Any ideas?

    PS running a debug exe gives the message "Failed to load platform plugin 'window'. Available platforms are: "

  • Well, it does seem like you are missing the platform plugin. Should be in a \platforms folder relative to the executable. Since the plugin is loaded during the runtime, you don't get the error messages you get when compile time linked dlls are missing. Also, potentially libEGL.dll and libGLESv2.dll

  • All in place :-(

Log in to reply