[Solved]Display only show mouse

  • Thanks for your advice.I just solve this issue now.But I don't know the root cause...

    when I cancelled gfx<drivers>, I found Qt assign me gfx driver with "linuxfb" & "muti screen".
    maybe muti screen is the key.

    Now I'm going to research Qt creator on embedded. :-)

    Hi all,I'm a new comer on Qt. I had encountered a issue on embedded porting.

    Here are my situation:

    1. I had modified path/mkspecs/qws/linux-arm-g++/qmake.conf with my cross compiler : " arm-hisiv200-linux ".
      ex.QMAKE_CC = arm-hisiv200-linux-gcc

    2. My configure:
      ./configure -prefix /opt/QtEmbedded-4.8.4-arm -release -opensource -shared -no-largefile -no-qt3support -no-xmlpatterns -no-webkit -xplatform qws/linux-arm-g++ -embedded arm -depths all -no-mmx -no-3dnow -no-sse -no-sse2 -qt-zlib -armfpa -little-endian -qt-freetype -qt-gfx-linuxfb -no-gfx-transformed -no-gfx-qvfb -no-gfx-vnc -no-gfx-multiscreen -nomake tools -nomake examples -nomake docs -nomake demos


    I can use the framebuffer example in path "/examples/qws/framebuffer" on my board . And I can see 3 blocks with Red,Green and Blue on the display.

    But when I tried to use other samples, it worked but only mouse on display.

    Dose anyone know this case? Thanks in advice.

  • is your platfrom a linuxfb platform (guess from -qt-gfx-linuxfb), I have a directfb based platform and I use -plugin-gfx-directfb, everything works for me.

Log in to reply