What are the green marks in editor in QtCreator? And how do I get rid of them?



  • Hi

    I am using dark vim theme along with FakeVim. It is all good and I love it but once in a while I get these green rectangles in white spaces or on the words. I do not know what they are and how to get rid of them. They drove me crazy ;( They are not like type names, function names etc. They just show up and might disappear when I delete the line. I can see that when I mark a line the Vim way I get these greenmarks too. But they are not always after marking, not sure why and how they show up, I wish I can change the color of those because theya re super bright and very distracting with the theme I am using.

    Screenshot

    http://s17.postimg.org/fdx9tbv4f/Capture.png

    thanks



  • Can you post an image of that please?





  • It is a very low quality image.
    I cannot see any rectangles in it.



  • [quote author="CAD_coding" date="1364362747"]It is a very low quality image.
    I cannot see any rectangles in it.[/quote]

    Can you try again please? I reposted the right link.



  • In the green portion of line containing co [ 0 ], is that space or tab?
    Just as a small advice, there is a an option in settings by which you add spaces instead of tab character when you press the tab key. Try applying that setting & see what you get.
    Since my color scheme is default I haven't seen such odd behaviour.
    Maybe others can answer that better.



  • [quote author="CAD_coding" date="1364363225"]In the green portion of line containing co [ 0 ], is that space or tab?
    Just as a small advice, there is a an option in settings by which you add spaces instead of tab character when you press the tab key. Try applying that setting & see what you get.
    Since my color scheme is default I haven't seen such odd behaviour.
    Maybe others can answer that better.[/quote]

    Hi

    Thanks for the advice however I use tabs only and I doubt these are visualization, because I have disabled such things. I also tried spaces instead of tabs, the result seemed to be same.

    I can get these shown by using ">>" (which is indent in Vim) , marking by "m-a" , and couple other mystical ways where I cannot tell how I create them in the middle of the coding sometimes I am not watching clearly.

    So I am not sure if it is a FakeVim or syntax highlighter issue :( I looked into the Color syntax there is not any bright green that I can identify as these.



  • The best thing you can do is file a bug report at "JIRA":https://bugreports.qt-project.org/secure/Dashboard.jspa. The concerned person will look into it but you should know how to reproduce it and you can attach the above image as well.


  • Moderators

    Could those lines use tabs for indention where Creator is configured to use spaces?



  • I resolved it by unmarking "Show position of text marks" in FakeVim General menu.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.