QtSerialPort from QtCreator



  • Hi guys,
    I am new in Qt, and I am trying to use the library QtSerialPort. I was following the steps of the wiki in order to run the examples inside, but I get an error by running it.
    I downloaded the qt-qtserialport-master, and I copy this folder into C:\Qt\Qt5.0.1\Tools\QtCreator\bin.
    Then I open the QtCreator and I open the project qtserialport.pro which is inside qt-qtserialport-master\qtserialport
    When I compile it, I do not get any problem, but when I run it, I got the error:

    Failed to start program. Path or permissions wrong?
    C:\Qt\Qt5.0.1\Tools\QtCreator\bin\qt-qtserialport-master\qtserialport-build-Desktop_Qt_5_0_1_MinGW_32bit-Debug\src\serialport\debug\QtSerialPort.exe exited with code -1
    Starting C:\Qt\Qt5.0.1\Tools\QtCreator\bin\qt-qtserialport-master\qtserialport-build-Desktop_Qt_5_0_1_MinGW_32bit-Debug\src\serialport\debug\QtSerialPort.exe...
    Cannot retrieve debugging output.

    The folder \qtserialport-build-Desktop_Qt_5_0_1_MinGW_32bit-Debug\src\serialport inside qt-qtserialport-master was created, but inside there is not any debug\QtSerialPort.exe. Here I can only find:

    • folders: .moc and .obj
    • files: MakeFile, MakeFile.Debug, MakeFile.Release, Qt5SerialPort_resource.rc, Qt5SerialPortd_resource.rc

    Can anybody help me???? I have already tried to run the qtserialport.pro from different paths in my Qt installation but no luck.


  • Lifetime Qt Champion

    Hi,

    As you know, QtSerialPort is not a program, it is a library so no executable will be generated.

    You have to create a new project using it in order to test it



  • Hi SGaist,
    thank you very much. My problem is that I did not know it. For any reason, I was thinking this project would create the libraries and a kind of user interface, where I can choose between the different example subprojects, which use the library.

    Thank u again and sorry for ur time

    The thread can be closed


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.