Qt Creator and Phonon



  • Hi !

    I downloaded Qt Creator 2.6.2 and I haven't any phonon section. Why ?

    Thanks


  • Moderators

    You have Qt creator installed. Have you also a version Qt libs installed?



  • What do you mean by Qt libs installed ? I tried to use visual studio 2012 so I built Qt successfull but I didn't succeed to get phonon. So I get back to Qt Creator


  • Moderators

    [quote author="mulfycrowh" date="1363644579"]What do you mean by Qt libs installed ? I tried to use visual studio 2012 so I built Qt successfull but I didn't succeed to get phonon. So I get back to Qt Creator[/quote]
    As it looks you have downloaded the Qt library source (hopefully as zip) and build with msvc 2012.
    You need to check the configuration you have actually built. Most options have a clearly defined default value for configuration. However, for Phonon the configuration was not clear e.g. configure of Qt 4.8 sais
    [quote] + -phonon ............ Compile the Phonon module (Phonon is built if a decent C++ compiler is used.) [/quote]
    So, possibly you have to set explicitly -phonon. For Qt 5 I could not verify.

    Qt creator is only an IDE as you have already with Visual Studio. If phonon has not been included while building Qt libs it will not be available in either IDE.



  • When I try to add -phonon in the configure parameters it's like having an error I don't get the license query


  • Moderators

    Which exact version are using Qt5.0.1 or Qt4.8.4?
    You need to post the error message of configure otherwise nobody will be able to help.



  • There is no error message but it stops while after displsying the help. It's Qt 5.0.1.
    As far I understand I need to build Qt to use it in VS.
    If I choose to use Qt Creator Do I need to build ? I don't think so. So why does Qt Designer not display the phonon ?


  • Moderators

    I do not use phonon and I do not use Qt 5, yet. So, it is hard to know what the problem could be.
    If you set the -phonon parameter with configure, it gives you a feedback describing the cause. Configure adds the different options as a help afterwards. However, at the beginning there should be a more detailed description, why the parameter has not been accepted. So check out what configure reports or post the response.

    Since you are using msvc2012 there are no prebuilds available and you have to compile Qt libs yourself, if you like to use msvc 2012 compiler.

    If you have downloaded qt creator from "here":http://qt-project.org/downloads#qt-creator this is just the qt creator IDE. It contains some compiled Qt libs, but only for qt creator use.

    You can download Qt 5.0.1 SDK with MinGW compiler. This is the most complete setup at the time. This includes Qt creator plus Qt 5.0.1 libs (compiled with MinGW) and the proper compiler. You need to download from "here":http://releases.qt-project.org/qt5/5.0.1/qt-windows-opensource-5.0.1-mingw47_32-x86-offline.exe

    However, I cannot guarantee that phonon is already included there. I simply do not know.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.