[SOLVED]Installation error for Qt 5.0.1 mingw 32-bit windows 7



  • Hi,

    When i tried to install the .exe file obtained from http://qt-project.org/downloads (Qt 5.0.1 for Windows 32-bit (MinGW 4.7, 823 MB)) onto my windows 7 desktop (32-bit OS), 2 errors come up:

    Error during installation process (qt.501.patcher): Qt patch error: Can not open C:/Qt/Qt5.0.1/5.0.1/mingw47_32/bin/qmake.exe. (The process cannot access the file because it is being used by another process).

    I have the option to retry, ignore, or cancel. No matter how many times i press retry, nothing will happen, so i decided to ignore it.

    After ignoring it, the examples aren't loaded, and i can't compile and run any code.

    Any clue??



  • Hi noob_g,

    I am not pretty sure, but still can you close all the other applications and try re installing.
    It clearly shows "The process cannot access the file because it is being used by another process" so I think there might be some other applications using it.



  • Hi Techtotie,

    Before installing, i have made sure there weren't any application running or whatsoever, still it doesn't work. :(



  • Hi noob_g,

          I am not sure of what might be causing this but you can refer to the following links for further actions.
    

    http://qt-project.org/forums/viewthread/1664

    https://bugreports.qt-project.org/browse/QTSDK-667



  • Thanks tectotie! I managed to solve it using method outlined here:
    http://qt-project.org/forums/viewthread/1664

    Basically, right click on the installer file (the .exe file), select properties. Under compatibility tab, tick the box that says "Run this program in compatibility mode for", then under the dropdown box select windows XP (Service Pack 3). Then just run the .exe file again as administrator.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.