Please nominate your Qt Champions for 2021!

Compilation's problem (Necessitas) [SOLVED]

  • Hi,

    I'm trying to compile the "empty" new project in QtCreator on PCLinuxOs 2012. After hundrends of attempts of compiling the program, I get always the same error:

    bq. 21:55:44: Creating package file ...
    21:55:44: Package deploy: Running command '/mnt/sda8/programy/Linux/necessitasSDK/apache-ant-1.8.4/bin/ant clean debug'.
    Buildfile: build.xml

    /home/tomasz/androidApp1/androidApp1/android/build.xml:90: The following error occurred while executing this line:
    /mnt/sda8/programy/Linux/necessitasSDK/android-sdk/tools/ant/build.xml:205: Class doesn't support the nested "matches" element.

    Total time: 1 second
    Packaging Error: Command '/mnt/sda8/programy/Linux/necessitasSDK/apache-ant-1.8.4/bin/ant clean debug' failed.Exit code: 1
    Error while building/deploying project androidApp1 (target: Necessitas Qt 4.8.2 for Android armv5)
    When executing step 'Packaging for Android'bq.

    I paste the screenshot too:

    I was looking for the solutions all the night, but I couldn't find anything useful. Did anyone here have the same problem? I'm tired and I know that I'm not able to solve it by myself.

    PS. I have installed Necessitas on Windows 7 too, but the program doesn't respond when I try to add new devices (emulators?). By the way, I would like to continue using my favourite system with KDE :)

    Thank you in advance who can help me.

  • I have installed apache-ant package and the problem is solved!

Log in to reply