Install of older versions



  • Is there any particular reason that the installation of older QT versions requires you to install creator separately from the designer? Due to my need for pyside, I had to install 4.8.4, but it is a pain in the neck. First I had to manually find the proper qmake because the creator installation can't automatically resolve that. Now, it is having trouble with mingw even though I have manually added the location of the compiler. The installation process seems terrible for the older versions. This is really unfortunate. Nobody wants to spend hours on end just trying to figure out basic installation issues.



  • While debugging a C++ program, I am receiving yet another message about something that needs to be compiled. It says that in Build and Run preferences that I should select a qt version, expand details, and select build all so that I have some nice debugger helper features compiled. I did that and I see no option to build all. I am using qtcreator 2.7 for win32. Has anyone else seen this issue? Can you tell me how to fix it?


  • Moderators

    From the looks of things, creating a flexible SDK is not trivial. The previous one, which packaged Qt Creator with Qt 4.6, was bound to Nokia and can't be used any more. However, the devs are in the process of making the Qt 5 SDK work with Qt 4.8 too. No release date in sight yet, though.

    BTW, The downloads page offers Qt libraries 4.8.4 for Windows (minGW 4.4, 317 MB). What version of MinGW/GCC are you using? GCC 4.7 is incompatible with GCC 4.4 -- compilation might still complete, but there will be mysterious crashes. If you have GCC 4.7/4.8, you can either downgrade to GCC 4.6, or compile the Qt libraries with your version of GCC


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.