[SOLVED] [Qt 5.0.1] Can't run any programs.



  • Every single program. From the code used for new projects to any example, results on this:
    @
    Starting program.exe...
    SHIMVIEW: ShimInfo(Complete)
    The program has unexpectedly finished.
    program.exe exited with code -1073741511
    @

    I've tried to reinstall Qt and the problem persists.
    My OS is a Windows 8 64 bits Pro.

    Does anyone have a clue about this issue?



  • i think its maby problem with administration acces ? do you try to run it as administrator ?
    win 8 have problems with couple develper ide`s :(

    sorry for my bad english :C



  • Nah, that's not the case :(

    Thanks for your reply anyway.



  • Does it work when you try to run in Debug mode?

    Try the following:

    1. Clean your project

    Close QtCreator

    Remove Release/Debug Folder
    Delete xxx.pro.user file
    Manually delete Makefile, Makefile.Debug, Makefile.Release (If still there)

    Open Qt Creator again and open your project. It should now be asking you to reconfigure your project build settings.



  • wakeuky, the problem is still there after those steps.

    I've read somewehere else that the problem is related to the MingW version, but I can't find a solution.



  • Did you update all of your environment variables after installing 5.0.1? How did you install 5.0.1? Did you use Git source, pre-compiled library, etc?



  • I've installed it using the installer provided by the downloads section.
    Using dependency walker I saw that the problem relies on libraries that weren't found, so I'm setting the environment variables now.



  • Can you provide a link/tutorial on the environment variables that need to be set?

    I'm having the same issues and after searching I ended up here.



  • I'm still fixing my problem, if what I'm doing solves the problem, I'll post it here.



  • Just add the binaries folder of Qt 5.0.1 to the path environment variable.
    For example:
    If it was like this before:
    @%SystemRoot%\system32;%SystemRoot%;...@

    Edit it to:
    @%SystemRoot%\system32;%SystemRoot%;C:\Qt\5.0.1\mingw47_32\bin;...@



  • That only points to the Qt bin. You should point to minGW bin as well (if using minGW obviously).

    Under Environment Variables, I have the following System Variables set:
    @QTDIR: D:\Qt\Qt5.0.1\5.0.1\mingw47_32@

    @Path: C:\Ruby200-x64\bin;C:\Python33;C:\Perl64\site\bin;D:\Qt\Qt5.0.1\Tools\MinGW\bin;xxx;D:\Qt\Qt5.0.1\5.0.1\mingw47_32\bin;@

    Note: I included Ruby, Python, and Perl as references as well. This was recommended in "this manual on building Qt5 from Git Repo ":http://qt-project.org/wiki/Building_Qt_5_from_Git . The Wiki post also recommends ensuring that Perl, Python, Ruby, and MinGW bin paths are included BEFORE Qt bin path. This could save you some time and potential hassle further down the road should you have to build from the source files.

    Cayan, glad to see you are running again!



  • I downloaded Qt 5.0.1 minGW47_32 recently but when I run an example an error occurs
    error : unrecognized "-fno-keep-inline-dllexport"
    file :cc1plus.exe not found
    help



  • @wakeuky, that's true, I forgot to mention about the compiler reference.
    @Zabb, add your compiler's path to the path environment variable as well.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.