Mac osx 10.7 lion unable to get past configure step



  • mac osx 10.7 i7 64 bit OS
    xcode 4.7 (latest) with command line tools installed
    qt-everywhere-opensource-4.8.4.tar.gz

    configure options:
    ./configure -universal -nomake demos -nomake examples -qt-zlib -qt-libtiff -qt-libmng -qt-libjpeg -qt-libpng -openssl -I /Library/postgresql/include -L /Library/postgresql/lib -debug-and-release -prefix /Library/qt -plugin-sql-psql -plugin-sql-odbc -plugin-sql-sqlite

    error returned right after accepting license agreement:
    Creating qmake. Please wait...
    g++ -c -o project.o -arch ppc -arch i386 -pipe -DQMAKE_OPENSOURCE_EDITION -g -fconstant-cfstrings -g -I. -Igenerators -Igenerators/unix -Igenerators/win32 -Igenerators/mac -Igenerators/symbian -Igenerators/integrity -I/Users/Greg/Documents/qt-everywhere-opensource-src-4.8.4/include -I/Users/Greg/Documents/qt-everywhere-opensource-src-4.8.4/include/QtCore -I/Users/Greg/Documents/qt-everywhere-opensource-src-4.8.4/src/corelib/global -I/Users/Greg/Documents/qt-everywhere-opensource-src-4.8.4/src/corelib/xml -I/Users/Greg/Documents/qt-everywhere-opensource-src-4.8.4/tools/shared -DQT_NO_PCRE -DQT_BUILD_QMAKE -DQT_BOOTSTRAPPED -DQLIBRARYINFO_EPOCROOT -DQT_NO_TEXTCODEC -DQT_NO_UNICODETABLES -DQT_NO_COMPONENT -DQT_NO_STL -DQT_NO_COMPRESS -I/Users/Greg/Documents/qt-everywhere-opensource-src-4.8.4/mkspecs/macx-g++ -DHAVE_QCONFIG_CPP -DQT_NO_THREAD -DQT_NO_QOBJECT -DQT_NO_GEOM_VARIANT -DQT_NO_DEPRECATED project.cpp
    llvm-g++-4.2: error trying to exec '/usr/bin/../llvm-gcc-4.2/bin/powerpc-apple-darwin11-llvm-g++-4.2': execvp: No such file or directory
    lipo: can't figure out the architecture type of: /var/folders/jd/yw9p7pg912ncp720k66pgkxh0000gn/T//ccmyHLFQ.out
    make: *** [project.o] Error 255

    Ideally I'd like to be able to compile qt for 64 bit and 32 bit support (-universal flag) but can't seem to get past the configure step! Any help is greatly appreciated!


  • Lifetime Qt Champion

    Hi,

    universal will also try to build for powerpc (the error you are seeing)

    Remove universal and add -arch x86 -arch x86_64, you should be fine then.



  • That worked great! Thank you for the quick response and solution!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.