Ubuntu theme integration after Qt 5.0.1 build



  • I built Qt 5.0.1 on Ubuntu 12.10.
    Everything worked fine, but when I open the Assistant or Designer it looks awful. The theme is not the one Ubuntu uses.

    It might have something to do with "Gtk theme support", which evaluated to "no" when I ran configure. I didn't find the libraries needed to get it built, however. (At least Google turned up nothing)

    How can I get the proper theme integration for my Qt 5 build?



  • Well, obviously I need libgtk2.0-dev
    Tested it with a new configure run so far. Now, there is a "yes" for "Gtk theme support". I'll rebuild and post my results here.



  • Ok, I rebuilt Qt5 with libgtk2.0-dev. It seems to have fixed the issue. The style is properly integrated with Ubuntu.

    Case closed.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.