Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Recompile 5.0.1 static



  • I followed the directions here:
    http://www.youtube.com/watch?v=chMNUzpN4pw
    from VoidRealms about how to rebuild Qt for static deployment.

    I'm trying to get a new environment up and running but am struggling badly. I can't get 4.8.2 with Ming up and running any more. I don't know why. So I figured I'd get 5.0.1 up and running. It's fully bundled and everything works.

    Unfortunately, I can't get the reconfigure process to work to recompile Qt for static builds.

    First, I couldn't find the Qt command line that sets the environment variables. I finally got configure on the path and got the environment variables set up.

    Now, when I try to run configure, I get:
    Error: Creating a shadow build of Qt requires
    perl to be in the PATH environment

    How do I get past this? Is there a document I can follow for rebuilding Qt for static deployment? Is there a prebuilt environment I can download and save myself the several hour compile?

    Thanks for any advice or guidance.


Log in to reply