Qt 5.0.1 : failed to initialize XrandR



  • Hello.

    I have a big problem with Qt 5 migration.
    Qt 5 and our app is installed on a Linux server. Then users telnet to this machine using different small terminals, some of them running old versions of X11, and use Export DISPLAY. We can't update those.

    With Qt 4 everything worked great.

    With Qt5 (maybe because of the X11->XCB switch, I'm not an expert on this) it's a nightmare. 99% of the users are stuck with the message "Xbc: Can't initialize XrandR". The other 1% users get the app displayed with the same error message, but with strange fonts and all the windows moves and resizes are EXTREMELY SLOW -> app unusable. 1 user only seems to have the app working nicely, and he seems to have XrandR 1.2.

    I tried compiling Qt with different configure options without any success. I need help otherwise, I really don't know how we'll manage to do the switch. Thanks!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.