Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Win7 32-bit Unable to get Creator 2.6.2(5.0 distribution) to work properly. Crashes



  • Hi,
    I've been having trouble ever since I've upgraded my Qt build to 5.0. Whenever i click a tab on the welcome screen, "Getting Started" "Develop" "Examples" or "Tutorials", Creator crashes. I can create new projects and open projects from the "Develop" tab that opens by default when you start Creator. I can also use the menu bar at the top with no problems. I've also noticed that when working on a QML project, opening up designer crashes Creator. I've tried getting a backtrace for the IRC community but the debugger doesn't seem to dumb any info.

    So, I thought I'd install it for VS2010, which worked fine, but there didn't find any support for QtQuick there and felt limited. I then decided to try to compile Qt, but after running @configure -debug-and-release -opensource -platform win32-g++@

    i got the errors

    bq. execute: File or path is not found (mingw32-make) execute: File or path is not found (mingw32-make) Cleaning qmake failed, return code -1

    so then i I learned that i could download a nightly build of creator. After doing that, I managed to load Creator without any crashes, but had problems loading the docs, i eventually found them and the documentation seems to all be working. but now i don't have the compiler and debugger etc. and setting it up has been fairly complicated.
    I've managed to find my settings for the version of QtCreator that crashes in

    bq. /Users/Username/AppData/Roaming/QtProject/qtcreator

    but i don't know how to import this information into the nightly build that i've installed. Could someone please help?

    Thanks

    -edit-
    I've searched the bug reports but was unable to find anything that looked like this. there were so many crash reports


  • Moderators

    I have not heard of such a crash as you describe yet. Can you please got a backtrace and "file a bug report":https://bugreports.qt-project.org/ so that we can fix the issue? Thanks!



  • Hello Tobias,
    I'd love to, but it seems the debugger doesn't work for me.

    i've got the machine assembly at least. I will submit ASAP. but could someone please help me with an alternative in the mean time?


  • Moderators

    You seem to have set up MSVC2010, not mingw, so try running configure with "-platform win32-msvc2010" (IIRC, I am not a regular windows user, check $QTDIR/qtbase/mkspecs for something that seems appropriate for windows and your compiler of choice).



  • Thanks for the suggestion but i have minGW installed as well. I thought the minGW compiler would be the best way to go for Qt. No matter, I'll try compiling with msvc



  • didnt work. I'll just go back to 4.8. I've submited the bug at least. hope it helps them.


Log in to reply