Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[solved] JOM problem in Qt Creator 2.6.2



  • I have downloaded Qt Creator 2.6.2, and have VS2010 installed on my system. I have added the path to the VS2010 bin directory to my PATH environment variable. I went to Tools/Options/Kits and selected WindowsKit, and set my compiler is set as Microsoft Visual C++ Compiler 10.0 (ia64) and my Qt Version was already found as Qt 4.7.4 (win32-msvc++10.0-64bit). With only these changes, I then:

    1. Created a new application - Qt GUI Application
    2. Took the defaults for Location, Kits, Details
    3. Ran build when everything came up

    I got the following error message that isn't very descriptive:

    ----------------------------------Start Compilation Text------------------------------------------
    17:05:08: Running steps for project SimpleGUITests...
    17:05:08: Starting: "C:\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\bin\qmake.exe" C:\Qt\QtProjects\SimpleGUITests\SimpleGUITests.pro -r -spec win32-msvc2010
    17:05:09: The process "C:\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\bin\qmake.exe" exited normally.
    17:05:09: Starting: "C:\Qt\qtcreator-2.6.2\bin\jom.exe"
    C:\Qt\qtcreator-2.6.2\bin\jom.exe -f Makefile.Debug
    c:\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\bin\uic.exe ..\SimpleGUITests\mainwindow.ui -o ui_mainwindow.h
    cl -c -nologo -Zm200 -Zc:wchar_t- -Zi -MDd -GR -EHsc -W3 -w34100 -w34189 -DUNICODE -DWIN32 -DQT_LARGEFILE_SUPPORT -DQT_DLL -DQT_GUI_LIB -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_3DNOW -DQT_HAVE_SSE -DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_THREAD_SUPPORT -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\include\QtCore" -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\include\QtGui" -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\include" -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\include\ActiveQt" -I"debug" -I"." -I"..\SimpleGUITests" -I"." -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\mkspecs\win32-msvc2010" -Fodebug\ @C:\Users\bmahfood\main.obj.7120.15.jom
    C:\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\bin\moc.exe -DUNICODE -DWIN32 -DQT_LARGEFILE_SUPPORT -DQT_DLL -DQT_GUI_LIB -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_3DNOW -DQT_HAVE_SSE -DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_THREAD_SUPPORT -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\include\QtCore" -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\include\QtGui" -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\include" -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\include\ActiveQt" -I"debug" -I"." -I"..\SimpleGUITests" -I"." -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\mkspecs\win32-msvc2010" -D_MSC_VER=1600 -DWIN32 ..\SimpleGUITests\mainwindow.h -o debug\moc_mainwindow.cpp
    jom: C:\Qt\QtProjects\SimpleGUITests-build-WindowsKit-Debug\Makefile.Debug [debug\main.obj] Error 2
    jom: C:\Qt\QtProjects\SimpleGUITests-build-WindowsKit-Debug\Makefile [debug] Error 2
    17:05:09: The process "C:\Qt\qtcreator-2.6.2\bin\jom.exe" exited with code 2.
    Error while building/deploying project SimpleGUITests (kit: WindowsKit)
    When executing step 'Make'
    ----------------------------------End Compilation Text------------------------------------------

    I am only just getting back into Qt, after having worked with other packages for a while, so I am not familiar with the JOM tool. I read that it is just a take off of nmake. Unfortunately, I have no idea how to debug this error message to see what is going on. Can someone give me a pointer here?

    Thanks...



  • I have run into the same issue quite recently (after a re-install) and I am yet to find a solution (despite numerous hours spent searching on the net).

    Although this doesn't solve your issue, a possible workaround is to simply use mingw instead.



  • What's the output if you turn off jom and use nmake instead?
    You can do that via Tools/Options..., then "Build & Run/General/Use jom instead of nmake".



  • errrm, I've just read it again and see that you set your compiler to ia64?
    Are you 100% sure that you're targetting Itanium?



  • Thanks. I made that changes and ran qmake (not sure I needed that) and then cleaned and built. I got the following:

    —————————Start Compilation Text————————————
    08:21:23: Running steps for project SimpleGUITests...
    08:21:23: Configuration unchanged, skipping qmake step.
    08:21:23: Starting: "C:\Program Files (x86)\Microsoft Visual Studio 8\VC\bin\nmake.exe"
    "C:\Program Files (x86)\Microsoft Visual Studio 8\VC\bin\nmake.exe" -f Makefile.Debug
    c:\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\bin\uic.exe ..\SimpleGUITests\mainwindow.ui -o ui_mainwindow.h
    C:\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\bin\moc.exe -DUNICODE -DWIN32 -DQT_LARGEFILE_SUPPORT -DQT_DLL -DQT_GUI_LIB -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_3DNOW -DQT_HAVE_SSE -DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_THREAD_SUPPORT -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\include\QtCore" -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\include\QtGui" -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\include" -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\include\ActiveQt" -I"debug" -I"." -I"..\SimpleGUITests" -I"." -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\mkspecs\win32-msvc2010" -D_MSC_VER=1600 -DWIN32 ..\SimpleGUITests\mainwindow.h -o debug\moc_mainwindow.cpp
    cl -c -nologo -Zm200 -Zc:wchar_t- -Zi -MDd -GR -EHsc -W3 -w34100 -w34189 -DUNICODE -DWIN32 -DQT_LARGEFILE_SUPPORT -DQT_DLL -DQT_GUI_LIB -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_3DNOW -DQT_HAVE_SSE -DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_THREAD_SUPPORT -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\include\QtCore" -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\include\QtGui" -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\include" -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\include\ActiveQt" -I"debug" -I"." -I"..\SimpleGUITests" -I"." -I"......\engineering-mirror\3rdParty\libraries\qt\4.7.4-fixed_vc10_exe\win32-msvc++10.0-64bit\mkspecs\win32-msvc2010" -Fodebug\ @.\nm4174.tmp
    NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 8\VC\bin\cl.EXE"' : return code '0xc0000135'
    Stop.
    NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 8\VC\bin\nmake.exe"' : return code '0x2'
    Stop.
    08:21:23: The process "C:\Program Files (x86)\Microsoft Visual Studio 8\VC\bin\nmake.exe" exited with code 2.
    Error while building/deploying project SimpleGUITests (kit: WindowsKit)
    When executing step 'Make'
    —————————Start Compilation Text————————————

    Do I somehow have to launch vcvarsall.bat before the build? And how would I do that?



  • [quote author="jobor" date="1360156462"]errrm, I've just read it again and see that you set your compiler to ia64?
    Are you 100% sure that you're targetting Itanium?[/quote]

    Oops, I'm wanting 64 bit, but the only other 64 bit option in my list of compilers is for amd64. I changed my kit to use the amd64 compiler and I'm up and running. Thanks for pointing that out.


Log in to reply