Qt 5.0.1 Failed to load platform plugin "windows"



  • Ok, first time installing Qt, ever.
    Start a new project -->Application-->Qt GUI Application.

    If I hit run on this, I should get an empty GUI window, or something. No ?

    Instead I get: Failed to load platform plugin "windows".


  • Moderators

    It's a new thing in Qt5 - QPA (Qt Platform Abstraction) plugins. You simply need to copy windows.dll (or was that qwindows.dll?) to <your executable dir>/plugins/platforms.

    Hope I remembered that well ;)



  • Ahm, where is that "windows.dll" typically found ?


  • Moderators

    <qt installation or source dir>/qtbase/plaugins/platforms



  • Thanks. Found it. There is actually a couple of them.
    One is in: C:\Qt\Qt5.0.1\5.0.1\mingw47_32\plugins\platforms
    The other in: C:\Qt\Qt5.0.1\Tools\QtCreator\bin\platforms

    Either one of them have no effect. Same error. I even tried pasting it in every single folder of this empty project. It is an empty project for crying out loud, I haven't even done anything and it fails.

    @Failed to load platform plugin "windows". Available platforms are:

    Invalid parameter passed to C runtime function.
    Invalid parameter passed to C runtime function.@



  • Ok, never mind. I tried to reinstall 5.0.1 just in case I missed some setting during installation, but now it will not even finish installing:

    @--------------------------- Installer Error --------------------------- Error during installation process (qt.501.patcher): The output of C:\Qt\Qt5.0.1\5.0.1\mingw47_32\bin\qmake.exe -query is not parseable. Please file a bugreport with this dialog https://bugreports.qt-project.org. output: "" --------------------------- Retry Ignore Cancel ---------------------------@

    Anyway, I am giving up on Qt for now, already spent too much time trying to get it properly seated on my system. Maybe this release is too buggy for some reason or not natively compatible with Win7 64.

    Cheers



  • Have you installed Qt with the admin privileges or as user?



  • See posting
    http://qt-project.org/forums/viewthread/21269
    I was using libGLESv2.dll and was having this problem: The pop-up
    ————————————————————————
    ..could not find or load the Qt platform plugin windows..
    ————————————————————————
    when trying to run the EXE-file. I could not resolve this until adding libEGL.dll to the same folder as my .EXE.
    Needs be fixed!
    Carl Stenquist, Renesas


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.