Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Urgent Help about QtCore4.dll



  • Hi!

    I'm new to Qt and with the whole programming scene and I have a bit of a problem.
    When I run my Qt project using QTCreator, it runs fine. But when I try to run it from the release folder ("DBMS-build-desktop-Qt_4_8_1_for_Desktop-MinGW__Qt_SDK__Release"), it gives me this error:

    "The procedure entry point ??0QVariant@@QAE@ABV0@@Z could not be located in the dynamic link library QtCore4.dll"

    I looked for some solutions online and so far none has worked. I tried to copy every QtCore4.dll from every directory under the installation path into the same folder as the .exe but still no avail.

    Thanks in advance! :D



  • Hi!
    Try with copy all files that the software "Dependecy Walker" says in the .exe directory. for example my aplication uses QtCore.dll, libgcc_s_dw2-1.dll, mingwm10.dll, QtGui4.dll and QtSvg4.dll


  • Moderators

    This could have to do with mixing library versions. If you compiled with - say - 4.8.4, but provide QtCore4 from 4.8.1, this kind of error might occur.



  • You could try those that are located in the Desktop directory in your installation.Hope this helps


Log in to reply