New installation of QT5 doesn't work --> cannot find -lGL



  • Hello,

    i use Kubuntu 12.04 LTS and Linux Qt5 for (x64).
    After installing "qt-linux-opensource-5.0.0-x86_64-offline.run" i created a Qt-GUI Project.
    But even the empty Qt-GUI Project aborts compiling with following errors:

    @20:57:42: Führe Schritte für Projekt Qt_GUI_Test aus...
    20:57:42: Unveränderte Konfiguration, qmake-Schritt wird übersprungen.
    20:57:42: Starte "/usr/bin/make" -w

    make: Entering directory /home/marco/QtProjects/Qt_GUI_Test-build-Desktop_Qt_5_0_0_GCC_64bit_SDK-Debug' g++ -m64 -Wl,-rpath,/home/marco/Qt5.0.0/5.0.0/gcc_64 -Wl,-rpath,/home/marco/Qt5.0.0/5.0.0/gcc_64/lib -o Qt_GUI_Test main.o dialog.o moc_dialog.o -L/usr/X11R6/lib64 -L/home/marco/Qt5.0.0/5.0.0/gcc_64/lib -lQt5Widgets -lQt5Gui -lQt5Core -lGL -lpthread /usr/bin/ld: cannot find -lGL collect2: ld returned 1 exit status make: Leaving directory/home/marco/QtProjects/Qt_GUI_Test-build-Desktop_Qt_5_0_0_GCC_64bit_SDK-Debug'
    make: *** [Qt_GUI_Test] Error 1
    20:57:42: Der Prozess "/usr/bin/make" wurde mit dem Rückgabewert 2 beendet.
    Error while building/deploying project Qt_GUI_Test (kit: Desktop Qt 5.0.0 GCC 64bit (SDK))
    Bei der Ausführung von Schritt 'Make'@

    Building console applications does work.
    I think I am missing the GL library.
    But why do I miss this library on my clean new installation?

    What can I do to make my QT5 run?



  • "sudo apt-get install libglu1-mesa-dev" .. maybe ?



  • Either a missing library or a bad symlink.



  • Thank you for the fast answer!
    I can compile and start the project now.

    But i still get this warning:
    @Starte /home/marco/QtProjects/Qt_GUI_Test-build-Desktop_Qt_5_0_0_GCC_64bit_SDK-Debug/Qt_GUI_Test...Qt at-spi: error getting the accessibility dbus address: "The name org.a11y.Bus was not provided by any .service files"
    Accessibility DBus not found. Falling back to session bus.
    /home/marco/QtProjects/Qt_GUI_Test-build-Desktop_Qt_5_0_0_GCC_64bit_SDK-Debug/Qt_GUI_Test beendet, Rückgabewert 0@

    What is "dbus"? Sounds like "debug bus"?
    Am I missing another package?
    Kubuntu tells me, that I am already using the "recent" version.
    But the name of the package is:
    libqt4-dbus

    Do I net a more resent library than Kubuntu offers?

    [quote author="seahumad" date="1359174@035"]"sudo apt-get install libglu1-mesa-dev" .. maybe ?[/quote]



  • http://qt-project.org/doc/qt-5.0/qtdbus/qtdbus-index.html

    I think I also get that warning on Fedora. I think that you need to install libatspi 2 and libdbus-1 packages, but since I don't use KUbuntu I don't know the exact package names.

    and no, you don't need a more recent version of libqt4-dbus. libqt4-dbus is part of Qt4 from your distribution, and you are using Qt5 now.



  • Installing libglu1-mesa-dev worked for me. Thanks!



  • Lubuntu 14 and Qt5, installing libglu1-mesa-dev fixed this issue too


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.