Problem: QT 4.8.4 statisch linken mit MySQL und OpenSSL (für QSslSocket)



  • Hallo Leute,
    Ich habe etwas in QT programmiert, was mit dynamisch gelinktem QT (alte QT Version aus dem SDK mit QT + QTCreator) einwandfrei läuft. Das Programm ist eine reine Konsolen Anwendung und nutzt zusätzlich MySQL und OpenSSL für
    den QSslSocket. Ich benutzt Ubuntu 12.04 und den QT Creator.
    Jetzt möchte ich wenn ich das Programm auf einen anderen Rechner spiele, nicht immer sämtliche
    Bibliotheken mitliefern, sondern hätte gerne alles statisch gelinkt.
    Meine bisherigen Versuche QT 4.8.4 statisch zu linken sind allerdings gänzlich fehlgeschlagen.
    Erstmal habe ich alle Pakete die hier aufgeüfhrt sind via Synaptic Packetmanager installiert.
    "QT X11 Requirements": http://qt-project.org/doc/qt-4.8/requirements-x11.html
    Weiterhin habe ich die Bibliothek libmysqld-dev und libsll-dev und openssl installiert.
    Wenn ich mein Projekt jetzt mit dem QT Creator öffne erhalte ich zahlreiche
    Build Probleme ala "undefined reference to SSlv_client_method" welche ganz offensichtlich
    Funktionen von mysql/ssl sind.
    Ich nehme stark an dass es an den configure flags liegt

    ./configure -static -debug -opensource -developer-build -qt-sql-mysql -L /usr/include/mysql -openssl-linked -L /usr/include/openssl -nomake demos -nomake exmaples -qt-zlib -no-qt3support -no-opengl -no-webkit

    Ich bin grad echt ziemlich frustriert, ich hab den ganzen Tag gegoogelt, aber nichts brauchbares gefunden.
    Wäre toll wenn mir jemand helfen könnte.
    Gruß Till



  • Damit hats glaube ich geklappt, werde mal testen ...
    ./configure -static -debug-and-release -opensource -developer-build -qt-sql-mysql -I /usr/include/mysql -openssl-linked -I /usr/include/openssl -nomake demos -nomake examples -nomake tools -qt-zlib -no-qt3support -no-opengl -no-webkit -prefix /usr/local/Trolltech/Qt-4.8.4_static


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.