[SOLVED] Builderror C1083 nevertheless using correct INCLUDEPATH in the pro file and #include directive



  • Hello,

    I have some problems with including header files from a different directory.

    For example, i have tried to include the shared_ptr.hpp Headerfile from the Boost-Library:

    I have added the additional include path in my *.pro file:
    INCLUDEPATH += /src/Boost/boost_152_0

    In my *.cpp File, I have added this line:
    #include <boost/shared_ptr.hpp>

    The parsing-step under the QT-Creator (v 2.6.1) works fine. For example, if i go with my mouse-pointer over the line #include <boost/shared_ptr.hpp> than the correct path "C:\src\Boost\boost_152_0\boost\shared_ptr.hpp" is visualized in a small popup-window. Even the jump function works fine and the include file shared_ptr.hpp will be opened correctly in the qt-creator.
    But just the build (QT 5.0.0 and Visual C++ 2010 x86 Compiler) don't works. I get the error C1083 ("can not open include file").
    Has anyone please an idea to solve this problem?

    Greets
    DiebBlue


  • Moderators

    welcome to devnet

    The only thing I see is that the drive letter is missing. Change to:
    @
    INCLUDEPATH += c:/src/Boost/boost_152_0
    @

    Try it even when it sounds odd. In general c should be the default drive.



  • Hey koahning, thanks for you reply.

    I have also already tested your suggestion with the full path (including the drive letter c:)

    INCLUDEPATH += c:/src/Boost/boost_152_0

    but unfortunately it also don't works. :-(


  • Moderators

    Did you rerun qmake?
    You can check also the generated makefiles to make sure that changes are in there.
    Are you using nmake or jom for build?



  • I have simply used the (re-)build button from the qt-creator :-). For build jom will be used. In my makefiles the includedirectory c:/src/Boost/boost_152_0 is still missing.


  • Moderators

    You should rerun qmake I guess.

    Go to in the projects menu on to the project and press the right mouse button. Below "Build" you find "run qmake".



  • YES, that works fine. I am so happy :-). Thank you a lot.

    Bye
    DiebBlue



  • Thank you, Koahnig. I spent over 5 hours trying to get this to work before stumbling on to your suggestion re qmake.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.