How to turn OFF fonts antialiasing everywhere?



  • Hi! I'm use some Qt apps under Ubuntu 12.10 (with Gnome). I need to change their outlook. I install qtconfig (qt4-config) and it work well except that i can't turn off antialiasing of any font, displayed at main area of window (i.e., i am not about menus/interface widgets etc.). I turn off antialiasing of non-Qt apps via gnome-tweak-tool. But it has no effect on my Qt apps.
    I search this forum and other places, but find only topics how to turn on antialiasing.
    The Qt apps itself can't be modified, they are binary only, the example is Xilinx ISE Webpack 13.4.
    Can i completely switch off any antialiasing engine of my Qt ?



  • I still not solved it. No one of multiple HOWTOs is work. No chances?..



  • I happen to be looking for this option and see this sniplet in here
    https://qt.gitorious.org/qt/jpasions-mobile-examples/commit/7c40149cf63877ee3d29ec34826ed2a63b4908f2

    // Disable antialias
    QFont noAA = QApplication::font();
    noAA.setStyleStrategy(QFont::NoAntialias);
    QApplication::setFont(noAA);
    

    Please try and see whether that fits your need.

    Regards,

    TTK



  • Edit your ~/.kde/share/config/kdeglobals
    Insert these lines:
    [General]
    XftAntialias=false
    XftHintStyle=hintmedium
    XftSubPixel=none


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.