[Solved] Qt 5 application won't start on non-development machine



  • Hello all,

    I have successfully ported a Qt application from 4.8 to 5.0. On the development machine (Win 7 32bit) everything runs fine as well in debug as in release mode.
    The only remaining issue is, when trying to run this application on another PC (tried Win 7 and XP, no Qt installation on either), it refuses to start; i.e. it only comes to the point, before the QApplication instance is created in main. No further errors or entries in the Windows event viewer can be found.

    Any suggestions how to fix this or how to catch up on the error?

    Tanks in advance!



  • Did you provide all the necessary libraries required to run the application, including the Visual Studio runtime, icu*.dll, libEGL.dll and libGLESv2.dll, platform/qwindows.dll and any other shared library your application links to?



  • Thanks for that quick reply!

    The platform/qwindows.dll was obviously missing! This wasn't necessary before Qt 5...
    I should have asked this question here some hours ago...

    Thank you again!



  • You're welcome.

    Platform abstraction has been changed in Qt5, now consisting of loadable modules, like platform/qwindows.dll for Windows. Those modules are loaded at runtime, so you won't get a warning from the dynamic linker if there are none.

    Feel free to prepend the title with '[Solved] ...' if your question has been solved to indicate that there is a solution inside.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.