Qt5Multimedia windows xp?



  • i've succesfully ported my application from qt4 to qt5, now using qtmultimedia instead of phonon..
    everything works ok, worked ok on other people i sent it using windows 7.

    however i tested it on some windows xp machines i have, and the playback does not start (i tried only remote http mp3 source)

    seeing the debug output in the windows xp machine, from the QMediaPlayer object the signal stateChanged(QMediaPlayer::State) is emitted, the only state i get is QMediaPlayer::StoppedState .

    the signal mediaStatusChanged(QMediaPlayer::MediaStatus) is not ever emitted.


  • Moderators

    Try a local MP3 file; does that work? How about other media types?



  • nope, local mp3 and local wav, exactly the same behavior (while in windos 7 these local files played as expected)



  • well i built it with the mingw version of qt5 (posted here http://qt-project.org/forums/viewreply/108035) and it works (at first didn't play on my machine win7, but i figured it needed these extra 2 dlls for some reason: Qt5MultimediaWidgets, Qt5OpenGL)

    now this runs on windows xp fine.

    tried again the msvc build with these extra dlls but still the same, not playing.


  • Moderators

    Hmm... sounds buggy.

    Have you tried both of:

    Transfer the working program from Windows 7 to Windows XP

    Compile the source code directly on Windows XP

    If you did and it still doesn't work, please file a bug report at https://bugreports.qt-project.org/



  • unfortunately i don't have the time for this, maybe another time if i find some windows xp available.

    however i just thought that it was some dll missing, though i copied all dlls from the msvc2010/bin folder in the .exe folder and still the same...

    another thing:
    with the msvc build if i set the url of an invalid file i just get from the the mediaStatusChanged changed signal the status QMediaPlayer::InvalidMedia.

    though with the mingw build the application freezes indefinitely (i have to kill it) and the last thing in the debug is: DirectShowPlayerService::doSetUrlSource: Unresolved error code 800c0006


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.