Qt haqida o'zbek tilida savollaringizni berishingiz mumkin bo'lgan forum.



  • Umumiy savollarga albatta asosiy forumdan javob qidirgan yaxshiroq, lekin ingliz tili bilan muammolar bo'lsa shu yerda savollaringizni o'zbek tilida berishingiz mumkin.



  • podprfgjsfogji zubmwi aqelk lakemnas mdf lasdf sumzeas'as !



  • yashi mi slar?



  • [quote author="Tutaum" date="1403896198"]podprfgjsfogji zubmwi aqelk lakemnas mdf lasdf sumzeas'as ![/quote]
    Qaysi tilda yozilganini tushunmadim :)



  • Salom ufo567
    Bu yerda sizni ko'rganimdan xursandman.

    Xa aytgandek "Qt Uzbekistan":https://qt-project.org/groups/qt-uzbekistan guruhiga qo'shilib qo'ysangiz yaxshi bo'lardi.



  • Hammaga salom.
    Men yaqindan beri QT ni o'rganayapman. Forumlarni o'qib bir narsaga tushuna olmadim. LGPL lisenziyada Statik kompilyasiya qilish qonunan mumkinmi?
    Oldindan katta rahmat.



  • Salom Dasturchi, forumga xush kelibsiz.
    lisenziya masalalari juda chalkash va yaxshisi yuristlar bilan gaplashgan maqul. Lekin ularga qo'yidagi umumiy izoh berish mumkin:
    Yaqingacha (Qt 5.3 gacha) Qt 3 hil lisenziya asosida tarqatilardi:

    • GPLv3 - yaratgan loyihangiz erkin dasturiy ta'minot qoidalariga asosan tarqatiladi. Ya'ni dasturingiz foydalanuvchilari sizdan dastur matnini talab qilishlari mumkin. Misol uchun sotishga mo'ljallangan dastur yaratsangiz sizdan shu dasturni sotib olganlargina dastur matnini talab qilishi mumkin. Va albatta dasturingizni istalgan ko'rinishda yig'ishingiz mumkin xohlang statik xohlang dinamik;
    • LGPLv2 - ushbu lisenziyaga asosan faqatgina dinamik kompilyatsiya qilishingiz mumkin va dastur izohlarida Qt dan foydalanganingiz haqida ma'lumot kiritishingiz kerak, lekin hech kimga dastur matnini berishingiz shart emas. Agar dasturingizni statik ko'rinisda yig'sangiz avtomat tarzda GPL lisenziyasiga o'tasiz;
    • Pullik versiyasi - sotib olganizdan keyin bilgan ishingizni qilaverasiz :).

    Qt 5.4 versiyasidan boshlab yangi LGPLv3 dan foydalanib boshlashdi. Ushbu lisenziyaning ma'nosini va LGPLv2 dan nimasi bilan farq qilishini xali oxirigacha tushunmadim. Yana bir muhim narsa, Qt 5.4 da yangi qo'shilgan modullar (Qt WebEngine va boshq.) faqat LGPLv3 asosida tarqatiladi lekin Qt 5.3 da mavjud bo'lgam modullardan LGPLv2 asosida foydalanish mumkin.



  • Salom qxoz, javobingiz uchun katta rahmat. Demak tinchgina LGPLv2 lisenzya bo'yicha kompilyasiya qilsam ma'qul ekanda.



  • Xa shunaqa. To'g'rirog'i LGPLv2.1. Albatta yangi komponentlardan foydalanmasangiz.



  • Yordamingiz uchun katta rahmat.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.