[Solved] Qt Build Problem with OpenSSL using MinGW



  • Hi all,

    I've tried to build Qt with OpenSSL using MinGW. But the following warning has been thrown at the stage of configure.exe. Also the mingw32-make of next stage has been failed. How can I get this MSVC warning although it is configured by MinGW (GCC compiler). I've used OpenSSL binaries (Win64OpenSSL-1_0_1c.exe), can it the reason of problem? Must I build the openssl from it's source with MinGW?

    generators/win32/msvc_vcproj.cpp:77 non-local variable '<anonymous struct> dotNetCombo []' uses anonymous type

    configure.exe -shared -debug-and-release -opensource -confirm-license -platform win32-g++ -no-exceptions -no-qt3support -qt-sql-sqlite -qt-zlib -qt-libpng -qt-libjpeg -no-webkit -nomake tests -nomake demos -nomake examples -openssl-linked -I C:\OpenSSL\include -L C:\OpenSSL\lib

    Thanks advance for your helps and clarifications,



  • The problem has been solved by building OpenSSL and Qt libraries from theirs source. There has been QtSDK with Qt 4.8.0 on my system before. Then I've built Qt 4.8.4 libraries with the last MinGW version in order to add openssl support. Now when I add Qt 4.8.4 build configuration from Qt Creator's projects settings, it crashes (forced to close). How should I do the transition between different Qt libraries built by different MinGW versions?

    Qt SDK 4.8.0 libraries built by C:\QtSDK\mingw\bin
    Qt 4.8.4 libraries built by the last MinGW version (C:\MinGW\bin)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.