Newbie question about installation on w7



  • Hello,
    I want to give a try qml and check it out.... but
    I've downloaded sdk from a link http://releases.qt-project.org/qt4/source/qt-win-opensource-4.8.4-mingw.exe
    i have error some might not work. And i did not work and my question is now: Is there any tutorial describing what i have to download and configure to make it work. For example nebeans was so easy install, create a new project, and compile.


  • Moderators

    What you've got yourself is not a SDK, it's just Qt libraries. You might need to get Qt Creator, too. Also, Qt libs you have are MinGW-based (compiled with mingw) but the compiler is not bundled in the package - you need to install it separately.

    "i have error some might not work" - now place yourself in my position and try to answer that? How the heck should I know what you mean? You need to provide some concrete data (error code, error message, what happened, what were you trying to do etc.).



  • Yes i install all qt lib qt creator and MinGW 5.1.6.
    Now i can create qml project but i cant 'compile' it is there any more i should do ?.
    Or maybe some install order?
    I did:
    1 qt creator
    2 MinGW 5.1.6
    3 qt libs


  • Moderators

    Would be better to install QtC last, but that does not really matter now. Open Qt Creator, go to Tools->Options->Build & Run->Qt Versions and check if your Qt version is there. If not, add it (you need to browse to where qmake binary is). Also, check if compiler was detected.



  • In qt version i have auto on qt 5 beta but i uninstall it and add manually qt.4.8(in my case it's c:qt\4.8.4\bin\qmake.exe). On compilators i have mingw(C:\MinGW\bin\mingw32-make.exe?? no idea is it right) and gcc (C:\MinGW\bin\gcc.exe).
    Still i don't see compile options as active any think else ?

    Still in design view:
    @
    import QtQuick 1.1

    Rectangle {
    width: 100
    height: 62
    }@

    i see results when i change some think. But i cant debug or build project.


  • Moderators

    Go to Projects pane, check if your project is configured for any of the toolchains. Maybe you had it set to Qt5 and did not update?



  • ok, i have no idea were Project pane is and how to check any directions ?
    Also when i open example project i can debug it and i can debug simple 'hello' my project, but when i close sample i cant debug my project?

    Still i cant build it to be alone version to run at windows...



  • ok i know what i did rong i open single file qml not project... still now i can debug but not 'build' as window app



  • i finally after some break know whats i did wrong. I did single file not project that's why i don't have build option. Still i made compiler C:\MinGW\bin\mingw32-c++.exe but seems not working. Any think more i need to do ?


  • Moderators

    Any errors pop up? Or you just cannot compile with that compiler?



  • I reinstall all and now worked after copy some dlls in to system 32 folder...
    Is there any way to not copy it to system32 some kinda link or some think?


  • Moderators

    Not sure about windows. Add the folder to $PATH?



  • Yes, in Windows the way to go is to add the folder of the dlls to PATH



  • Well i click my Computer management -> advanced-> variables on bottom and i add:
    C:\MinGW\bin
    C:\Qt\4.8.4\bin

    in user variables and system variables is it enough ?


  • Moderators

    Haven't you tried?



  • i did :) well not worked for me. And than i copy paste few dll that exe scream for. Still maybe i should restart pc any way going to try write some code alone thx for help :)


  • Moderators

    Well, not a perfect solution, but at least it works. You can try MSVC next time, there is a little less problems with it.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.