[Solved] QNetworkAccessManager apparently giving "error: symbol(s) not found for architecture x86_64"

  • Hi, I'm fairly green in the use of Qt, but so far it seems great! I'm currently working on something where i need to use the QNetworkAccessManager, but I'm getting this boring linker error, which indicates that I'm using something that's 64-bit only, which i find rather odd. I've located the problem to these two lines of code, which has interdependency, so it could be the QNetworkReply too.
    @QNetworkAccessManager manager(this);
    QNetworkReply *replyPtr = manager.get( QNetworkRequest( url_ ) );@

    If i comment out these two lines, everything works fine.

    Would be nice if anyone has seen a similar problem, and have a solution.

    Some useful information:

    • Running Mac OS X 10.7.4
    • Qt Creator 2.4.1, based on Qt 4.7.4 (64 bit)
    • Compiling for desktop Qt 4.8.1
    • Got the same error before because of some copy/paste from the web, resulting in some invalid characters, but this time i've written everything myself.

  • Do you have
    QT += network
    in your .pro file?

  • Nope, did the trick! Thank you so very much! :-)

  • Glad it did the trick! It's a common mistake to make. :-) Be sure and edit your initial post to add [Solved] to the title. Thanks!

Log in to reply