My chrome extension for QtDevNet



  • Thanks
    This time the icon is working. It shows the number of unread posts. But when clicking on icon, it got an error message. It gives return code 12 ( net::ERR_INSUFFICIENT_RESOURCES ).
    Also trying to open options gives the same error.
    This is on Win7 64bit, Chrome 12.0.742.100.



  • I randomly have the same issue same platform same chrome version.
    [quote author="koahnig" date="1308843951"]Thanks
    This time the icon is working. It shows the number of unread posts. But when clicking on icon, it got an error message. It gives return code 12 ( net::ERR_INSUFFICIENT_RESOURCES ).
    Also trying to open options gives the same error.
    This is on Win7 64bit, Chrome 12.0.742.100. [/quote]



  • Tested it on latest stable chrome on Ubuntu Natty (amd64) and same thing.



  • @ucomesdag Thanks for your feedback

    @vass
    I have installed it on another machine. It was never installed there. So I thought to give it a try.
    It installed and shows the number of unread posts. It also showed a window once, when I was clicking on the icon. That looked ok. But that was the only time. Any additional try will result in the same error message.
    When looking at the Crome task manager it is announce to use quite a bit of cpu time of up to 5% on quad core. At least the memory consumption seem to be bit out of proportion. It was increased starting around 6MB up to more than 90 MB. On the other machine it is around 200 MB now, but both are still increasing.

    Please let me know, if you require more details.

    BTW It is a great gadget. So, sorry for dumping all the garbage on you :-)



  • I think I found problem, some setting value not initialized for first start. I uploaded new version. For clear test, please, try remove old version and install new (not update)



  • Hi Vass, thanks for update.
    I have followed your advise. The new download seems to work like a charm. Excellent Job!!

    By seeing the features now, my rating is REALLY AN EXCELLENT TOOL, not just an excellent gadget.

    The memory leak seem to be gone. The memory use is around 6-9 MB now. I will keep an eye on it and report difficulties, if there are any.



  • Wow, after update it shows minimal traffic and only 7mb of memory, nice!



  • @koahnig, @mariusg Yeaahhh! :)



  • Updating, disable, re-enable and saving the options worked for me! Excellent work Vass!
    [quote author="Vass" date="1308903625"]I think I found problem, some setting value not initialized for first start. I uploaded new version. For clear test, please, try remove old version and install new (not update)[/quote]



  • Hi Vass,

    you have solved the problem with the tool. It works. While observing the allocated memory it seems to be typically around 6MB. So, it works fine.

    While playing a little around I have noticed a couple of things. So, I take the liberty to suggest some possible modifications.
    When pressing "Mark all read" on the "New post" tab the count in the icon is reset, but the last list of posts is still visible until you open through clicking on the icon. Changing the tabs to "Home" and back does not update the contents (neither the count on "Home" nor the list). That is a bit irritating, but more cosmetics.
    Another point is: When opening the menu you are ending up at the home tab. Some users may wish to see immediately the "New posts" tab. Possibly this could be part of settings, where you are ending on opening.



  • @koahnig Good ideas. I will try realize it as soon as possible



  • cool, danke!



  • Thanks for this extension. It is very useful for me.



  • Hello everyone!

    Extension was updated.

    Changelog:

    • Adaptation for qt-project.org
    • One bug fix
    • DevNet is not "beta" now. So my extension version has changed to 1.0 :)

    Enjoy!



  • I'll try it!



  • Great plugin "+1"

    I would love to see increasing the features.



  • Hi!
    Plugin stopped update a few days ago. Something has changed, or is the problem on my side?



  • It works ok for me.



  • Yes, its works now.
    i guess problem was on my side.
    Is possible manually refresh data?


  • Moderators

    Yeah, just restart your browser. And remember to keep cookies from QtDN.



  • I'll give it a try. Does the plugin still get updates?


  • Moderators

    [quote author="onek24" date="1391784322"]I'll give it a try. Does the plugin still gets updates?[/quote]

    I don't know if it is being updated, but it still works without problems and is actually very useful :) I have it installed on my Chrome.



  • [quote author="onek24" date="1391784322"]I'll give it a try. Does the plugin still get updates?[/quote]
    The plugin does still work.



  • Yes i have installed it and it is working fine so far, also it is very usefull too. It is a little bit slow but i don't think that this is a plugin-issue.


Log in to reply