Error : ?nextNode@QHashData@@SAPAUNode@1@PAU21@@Z could not be located in the dynamic link library QtCore?4.dll



  • why error : ?nextNode@QHashData@@SAPAUNode@1@PAU21@@Z could not be located in the dynamic link library QtCore?4.dll this happen?

    I put my .exe file and all of the needed dll in a folder. when I run, I face with this error...
    Os: win7 64


  • Moderators

    Might be a DLL mismatch. If you compiled your app with Qt 4.8.3, for example, it's best to use DLLs of the same version, build with the same compiler (MSVC and mingw are not binary compatible).

    Qt obviously has binary compatibility promise, but it's - understandably - only kept one-way: you can run an older binary with newer DLLs, but not vice versa.



  • [quote author="sierdzio" date="1352637228"]Might be a DLL mismatch. If you compiled your app with Qt 4.8.3, for example, it's best to use DLLs of the same version, build with the same compiler (MSVC and mingw are not binary compatible).

    Qt obviously has binary compatibility promise, but it's - understandably - only kept one-way: you can run an older binary with newer DLLs, but not vice versa.[/quote]

    yes, now its working.. thanks alot


  • Moderators

    Pleasure, happy coding!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.