MinGW64, Qt 4.8.3



  • I am unsucessfully compiling Qt with MinGW64. There are wiki pages (http://qt-project.org/wiki/MinGW-64-bit, http://qt-project.org/wiki/Building_Qt_Desktop_for_Windows_with_MinGW) and a few posts in forums suggesting that it is works.

    I am compiling on plain MSYS with gcc/rubenvb-4.7.2 build. I unpack and configure (in bash console) using

    @tar xfz qt-everywhere-opensource-src-4.8.3.tar.gz
    cd qt-everywhere-opensource-src-4.8.3
    ./configure.exe -prefix c:\MinGW64 -release -opensource -confirm-license -shared -fast
    -no-webkit -no-multimedia -no-xmlpatterns -no-qt3support
    -no-accessibility -no-script -no-declarative
    -no-dsp -no-vcproj -no-s60 -largefile
    -qt-zlib -qt-libtiff -qt-libpng -qt-libmng -qt-libjpeg
    -platform win32-g++-4.6 -nomake tests -nomake examples
    @

    which successfully configures the project with

    @Sources are in..............C:\src\qt-everywhere-opensource-src-4.8.3
    Build is done in............C:\src\qt-everywhere-opensource-src-4.8.3
    Install prefix..............c:\MinGW64
    Headers installed to........c:/MinGW64/include
    Libraries installed to......c:/MinGW64/lib
    Plugins installed to........c:/MinGW64/plugins
    Imports installed to........c:/MinGW64/imports
    Binaries installed to.......c:/MinGW64/bin
    Docs installed to...........c:/MinGW64/doc
    Data installed to...........c:/MinGW64
    Translations installed to...c:/MinGW64/translations
    Examples installed to.......c:/MinGW64/examples
    Demos installed to..........c:/MinGW64/demos
    @

    and bootstraps qmake. Running @mingw32-make@ however immediately results in

    @C:/src/qt-everywhere-opensource-src-4.8.3/bin/qmake C:/src/qt-everywhere-opensource-src-4.8.3//projects.pro -o Makefile -spec win32-g++-4.6
    Could not find mkspecs for your QMAKESPEC(win32-g++-4.6) after trying:
    c:/MinGW64\mkspecs
    Error processing project file: C:/src/qt-everywhere-opensource-src-4.8.3//projects.pro
    make: *** [all] Error 3
    @

    Any hints? Thanks!



  • As workaround, I did @cp -r mkspecs /c/MinGW64/mkspecs@ , it compiles now. Explanation of the error still appreciated.



  • I'm not sure why you're wanting the set the -prefix parameter to the same folder as your compiler.

    Try not setting this parameter, and see what happens. By default, QT will build to C:\Qt\4.8.3.



  • I want to have separate dirs for every compiler I use. Under Linux, Qt has the same prefix as all system-installed programs (/usr - Unix System Resources) anyways, and it works.


  • Moderators

    [quote author="eudoxos" date="1352474657"]Explanation of the error still appreciated.[/quote]

    What is not clear? Qt built with -prefix puts the output files of it's compilation to the prefixed folder. It does not copy the mkspecs. That is partially why the most common way is to use:
    @
    -prefix $PWD
    @

    or:
    @
    -prefix CD
    @

    if you happen to live on Windows (CD should be wrapped in percent signs, but this site strips them, so I cannot put them there).



  • Configure.exe creates configuration which does not compile. That is not OK.

    If it works only for -prefix $PWD, then it should be documented and checked by configure.exe.


  • Moderators

    You can set QTDIR and it should compile.

    Apart from that I agree, it probably should copy the mkspecs.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.