Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Configure Qt5



  • Hi
    I downloaded Qt5 and ran the following configure command
    configure -platform win32-g++
    This gave me the following error

    cc1plus.exe: error: unrecognized command line option "-fno-keep-inline-dllexport"
    mingw32-make: *** [tmp/obj/debug_shared/arch.o] Error 1

    What can I do to fix this?

    Thanks

    Graham



  • You need a GCC version >= 4.6 to build Qt5.

    You can find a recent version "here":http://sourceforge.net/projects/mingwbuilds/.



  • Hi
    Thanks for your quick reply
    I have downloaded the latest mingw compiler and the configure command ran successfully
    However, the build fails

    codecs\qtextcodec.cpp: In function 'void setup()':
    codecs\qtextcodec.cpp:269:16: error: expected type-specifier before 'QIconvCodec'
    codecs\qtextcodec.cpp:269:16: error: expected ';' before 'QIconvCodec'
    mingw32-make[4]: *** [tmp/obj/debug_shared/qtextcodec.o] Error 1
    mingw32-make[3]: *** [debug-all] Error 2
    mingw32-make[2]: *** [sub-corelib-make_first] Error 2
    mingw32-make[1]: *** [sub-src-make_first] Error 2
    mingw32-make: *** [module-qtbase-make_first] Error 2

    any idea on how to fix this?

    Thanks

    Graham



  • You are most probably using an outdated Qt5 (the mentioned error has been fixed in "Ic3c4ccce":https://codereview.qt-project.org/33691).

    Either download the latest sources or, as I would recommend, clone latest from git.



  • I downloaded 32 bit windows mingw version of 5.0.1 yesterday and I get the same error when compiling my project.



  • I have the same problem exactly on Win XP. I downloaded the MinGW 32 bit version of Qt 5.0.1 install so MinGW, gcc, and g++ in the installed bin should all be up to date - I would think? ? ?



  • On another forum I found a single post that suggested to use the option arguments :

    @
    -no-qt3support CXXFLAGS="-fno-keep-inline-dllexport"
    @

    This worked on my system. It may work for yours as well Graham.


Log in to reply