QtCore4.dll problem with 4.8.3 and 4.5.2?



  • Hello,

    I have some code that was developed previously using QT Version 4.5.2. I can run the executible that was compiled previously, and I am even able to recompile the files on my machine, but I am unable to run the newly compiled executible file. I think this may be related to the fact that I am now using QT version 4.8.3. Do you have any suggestions to make this work? I have been trying to download a 4.5.2 version of QT but all I found is the opensource version 4.5.3, and this does not seem to be complete (there is no qmake.exe file).

    Some more information:

    The error that I get when I try to run the new executible is relat: The procedure entry point ?detach_grow@QListData!!QAEPAUData@1@PAHH@Z could not be locatedin the dynamic link library QtCore4.dll I used Dependency Walker on both the working old executible, and my compiled by not working executible, and the older file doesnt even run this function, instead runs something calleded detach2.... which is why I think it may be related to the two different versions. Also, I checked and the .dll file from the error message that causes the problems (QtCore4.dll) is being used from the same location for both the working-old file and the non-working-new file.

    Any suggestions are greatly appreciated!

    Thank you!



  • Just a follow-up, it looks like the problem was that the 4.5.2 dlls were incompatible with the 4.8.3 compiled .exe. Also, I needed both QtCore4.dll and QtGui4.dll to be updated. Thanks!



  • Every Qt version are packaged with their respective libraries (.dll).

    QtCore4.dll and QtGui4.dll should be on your [Qt 4.8.3 directory]/bin/

    All you need to is copy the dlls that you need and replace those dlls that you used for 4.5.2.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.