QtWebkit does not support mpeg4?



  • I made ​​a simple WebBrowser using the [QWebView] to install the [Qt SDK version 1.2.1].
    Platform is [Windows7 64bit].
    You do not have to say anything comfortable operation.

    I can not play the [mpeg4] of [QWebView] but in html5.
    [QtWebkit] does not support [mpeg4]?
    You will need to be installed on or other?

    I may have some parts that lack of explanation in the lack of knowledge.
    Lest they should be completed in a hurry, I would like some tips and advice, however.

    Thank you.



  • You might want to enable platform plugins to enable such support as described here in the "documentation":http://qt-project.org/doc/qt-4.8/qwebsettings.html#enabling-plugins.



  • Thank you for an answer.
    I did not know how to enable the concrete.
    I just use something like this but I found a sample?
    This sample was not playing mpeg4 way.
    I'm glad if you give me advice on how to use the function.

    @
    MainWindow::MainWindow(QWidget *parent) :
    QMainWindow(parent),
    ui(new Ui::MainWindow)
    {
    ui->setupUi(this);

    QWebSettings::globalSettings()->setAttribute(QWebSettings::PluginsEnabled, true);
    QWebSettings::globalSettings()->setAttribute(QWebSettings::AutoLoadImages, true);
    
    QWebSettings::globalSettings()->setAttribute(QWebSettings::JavascriptEnabled, true);
    QWebSettings::globalSettings()->setAttribute(QWebSettings::OfflineStorageDatabaseEnabled, true);
    QWebSettings::globalSettings()->setAttribute(QWebSettings::OfflineWebApplicationCacheEnabled, true);
    QWebSettings::globalSettings()->setAttribute(QWebSettings::LocalStorageEnabled, true);
    
    ui->webView->load(QUrl("http://"));
    

    }
    @

    Is it like form or under?
    Did not succeed to build the form below.

    @
    MainWindow::MainWindow(QWidget *parent) :
    QMainWindow(parent),
    ui(new Ui::MainWindow)
    {
    ui->setupUi(this);

    ui->webView->setAttribute(QWebSettings::PluginsEnabled, true);
    
    ui->webView->load(QUrl("http://"));
    

    }
    @


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.