Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Help with Ibase plugin on Mac os X



  • Hi guys,
    i've Mac 10.6.2
    qt version:4.8.1

    i'm trying build the Ibase(firebird) plugin for qt, but i have some problems...
    these are the steps:

    I download src.
    I build my driver:
    @make -spec macx-g++ -o Makefile "INCLUDEPATH+=/Library/Frameworks/Firebird.framework/Versions/Current/Headers" "LIBS+=-L/Library/Frameworks/Firebird.framework/Versions/Current/Libraries -lfbclient" ibase.pro@

    Now i copy libqsqlibase.dylib libqsqlibase_debug.dylib in to the sqldriver folder.

    My project serch the plugin in the correct folder because I have checked with the following command

    DYLD_PRINT_LIBRARIES=1 QT_DEBUG_PLUGINS=1 ./miapp.app/Contents/MacOS/miapp

    bug:

    @QFactoryLoader::QFactoryLoader() looking at "/Users/dani/QtSDK/Desktop/Qt/4.8.1/gcc/plugins/sqldrivers/libqsqlibase.dylib"
    In /Users/dani/QtSDK/Desktop/Qt/4.8.1/gcc/plugins/sqldrivers/libqsqlibase.dylib:
    Plugin uses incompatible Qt library
    expected build key "macosx macx-cocoa g++-4 full-config", got "macosx macx-cocoa g++-4 no-pkg-config"@

    How i can change no-pkg-config building to full-config?

    what's my problem? Thank you



  • I think I've found the problem, but not if it is the best way or not, some expert clarify me a bit.

    I knew that had to be a line to indicate that version had to compile, then I went to spotlight and search, "no-pk-config" giving me qconfig.h resulting file located in the folder src / corelib / global
    there is one line that said something like:

    @ define QT_BUILD_KEY "macosx-cocoa macx g+ + -4 no-pkg-config"@

    change it to

    @ # define QT_BUILD_KEY "macosx-cocoa macx g+ + -4 full-config"@

    which was what I needed.

    And surprisingly it worked, did not give any issue in the future?


Log in to reply