./QtSdk-offline-linux-x86_64-v1.2.1.run: Permission denied



  • I am in the process of trying to get a 32 bit project I completed to work on a 64 bit machine. I installed my 64 bit Ubuntu and while trying to install the Qt 64 bit SDK I downloaded via the web, I get the error ./QtSdk-offline-linux-x86_64-v1.2.1.run: Permission denied. Can someone point me to the right direction to get me going? Possibly a Qt install guide? Thanks!


  • Moderators

    There are several possible reasons for this error message:

    The file is not executable. Run "chmod 755 ./QtSdk-offline-linux-x86_64-v1.2.1.run" and try again.

    The file is in a format that the kernel does not understand. This happens when trying to run a 32bit application on a 64bit only machine (or the other way around). Try running "file ./QtSdk-offline-linux-x86_64-v1.2.1.run" and make sure the binary matches your environment. Also run "dpkg -print-architecture" (not 100% sure about this one) to make sure you are really running the environment you expect.

    The filesystem does not allow executable files in the directory you are in. Move the file somewhere else and try again.

    There are probably more reasons for this error message, but these are the ones I ran into so far;-)



  • thanks for your quick response Tobias. However, running “chmod 755 ./QtSdk-offline-linux-x86_64-v1.2.1.run” gets rid of the error but it does not do anything. I even tried running it from another directory. Any ideas?



  • nevermind Tobias.. I found it "here":http://qt-project.org/forums/viewthread/7333


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.