[Qt Creator Plugin]



  • Hello,
    I would like to create a plugin for my qtcreator, but when compiling, I get an error that I do not understand.
    Thank you for bringing your help.
    Here is the end of the compilation output:
    @c:/qtsdk1.2.1/mingw/bin/../lib/gcc/mingw32/4.4.0/../../../../mingw32/bin/ld.exe: cannot find -lAggregationd
    collect2: ld returned 1 exit status
    mingw32-make[1]: *** [..\qtcreator-build\lib\qtcreator\plugins\MyCompany\MyPlugind.dll] Error 1
    mingw32-make: *** [debug] Error 2
    07:41:34: Le processus "C:\QtSDK1.2.1\mingw\bin\mingw32-make.exe" s'est terminé avec le code 2.
    Erreur lors de la compilation/déploiement du projet myplugin (cible : Desktop)
    Lors de l'exécution de l'étape "Make"@


  • Moderators

    It does not find the Aggregation library (debug version). Is the library with that name there (Aggregationd.dll) in the PATH or in the call to the linker?

    Did you declare the necessary dependency for your plugin?



  • The solution I found is to recompile qt creator to have the dll I'm missing.
    Or do you know where I can find the dll?



  • I finally came to the compilation. And the process terminates normally.
    But I can not see my plugin.
    Because I have this compilation error output
    @Error reading C:/Qt/qtcreator-2.5.2/share/qtcreator/Nokia/toolChains.xml:7: Fin de document inattendue.
    Warning: Unable to restore tool chain 'Qt4ProjectManager.ToolChain.Maemo:{f9da3153-41a3-4804-8dce-626294592f6d}' stored in C:\Users\Boris\AppData\Roaming\Nokia\toolChains.xml.@


  • Moderators

    That is a) happening at runtime, not compiletime and b) only a warning that you can most likely ignore.

    Is your plugin properly installed? If it is, then it will be listed in Help->About plugins. Make sure the "Load" checkbox is ticked, otherwise creator will just ignore it. If the loading failed this dialog should provide some hints as to what went wrong.



  • Its not working. I tried everything. I still have the same error.


  • Moderators

    Ignore the output, it is not critical in any way.

    What does Help->About plugins say about your plugin? Is it listed?

    Have you checked the dependencies of your plugin (e.g. running depends.exe on your binary)? Is everything found?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.