Workarounds for various build issues with Qt5 beta1



  • Hi,

    I've just finished building Qt5 beta1 for Embedded Linux with the Sourcery-G++ toolchain, using OpenEmbedded ("github repository":https://github.com/kromain/OpenEmbedded-Archos/tree/qt5 )

    My OE branch is quite old, so I've had to work around a few issues to make it build. This post is mainly intended as a time saver for other people who may hit the same issues.

    h2. configure immediately barfs with errors like "cannot stat file ..."

    -> your perl version is too old, Qt5 b1 needs at least 5.14.
    My OE came with a perl-native that was 5.8 which doesn't work for Qt. I've fixed it by adding
    @ASSUME_PROVIDED += "perl-native"@

    h2. [...]::isNull is not defined (from qvariant_p.h)

    -> C++11 support is detected while GCC doesn't properly support it
    Fixed by passing
    @-no-c++11@
    to the configure options

    h2. qopengles2ext.h:921: error: 'GLchar' has not been declared

    -> the GLES2/gl2.h header from the OpenGL driver is outdated, see discussion at http://comments.gmane.org/gmane.comp.lib.qt.devel/5867
    I personally fixed it by patching qopengl.h with
    @typedef char GLchar;@

    h2. cc1: fatal error: .pch/release-shared/QtGui: No such file or directory

    -> currently unresolved bug with the build of assembly files, see discussion at http://comments.gmane.org/gmane.comp.lib.qt.devel/5933
    Fixed by passing
    @-no-pch@
    to the configure options

    h2. ld: hidden symbol `void QQmlThread::postMethodToThread<QQmlDataBlob*, QQmlDataBlob*, QQmlDataLoaderThread>(void (QQmlDataLoaderThread::)(QQmlDataBlob), QQmlDataBlob* const&)' isn't defined

    -> bug with GCC versions < 4.4.x, see bug report at https://bugzilla.redhat.com/show_bug.cgi?id=493929
    Fixed by adding
    @QMAKE_CXXFLAGS_RELEASE += -fno-inline@
    in qtdeclarative/src/qml/qml.pro

    Feel free to add your own fixes or future ones in there.



  • Arf, this would make a lot more sense in the wiki instead, silly me.

    Contents moved to http://qt-project.org/wiki/Building-Qt-5-from-Git instead



  • cool, I encounter this problem and got fixed here , thanks Kromain .


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.