QDesktop openUrl problem in symbian



  • Hi,

    I am using @QDesktopServices::openUrl()@ to open browser with given URL from my Qt application. It opens the given URL in default browser, but when the default browser is already opened it will not reloaded my application given URL.

    Thanks in Advance



  • Sounds like this should be submitted as a bug:

    http://bugreports.qt.nokia.com

    Please attach a small reproducible example to the report as well.



  • Thanks for the reply. Ok, I'll submitted as a bug.

    I have one solution for that, i.e detect the browser process, if it is running then kill the browser and execute the command "QDesktopServices::openUrl()".

    But I am trying to find the sample for detecting the running browser with the QProcess, so that i'll kill browser process.
    If you know how to that then kindly let me know.

    Thanks



  • QProcess will not allow you to find running processes that were not started by you. If you really want to find the Browser process you will have to use native Symbian APIs, most likely something from the APPARC frameworks (eg: TApaTaskList). Note that if you plan on actually killing another process, this will require the "PowerMgmt" capability which probably isn't worth getting just to work around this bug.


  • Moderators

    Could you please provide a link to the bug you posted (and tag this post with the bug id)? Thanks.



  • Hi jbarron,

    Ok, but it is important to our application that it opens the webpage.

    I also try to use QWebview control but in this control it can't handle the javascript and application crashes. if you were trying QWebview to open the facebook then you will see the javascript problem.

    Due to javascript problem I am using default browser. But it also buggy.

    Tell me what should i do its client requirement and its urgent.

    Thanks



  • [quote author="smotiwala" date="1291020589"]Hi jbarron,

    I also try to use QWebview control but in this control it can't handle the javascript and application crashes. if you were trying QWebview to open the facebook then you will see the javascript problem.

    Due to javascript problem I am using default browser. But it also buggy.
    [/quote]

    is javascript enabled? also check what other websetting you are trying to use
    @
    QWebSettings::globalSettings()->setAttribute(QWebSettings::JavascriptEnabled, true);
    @



  • Following settings i have used for QWebview

    QWebSettings::globalSettings()->setAttribute(QWebSettings::JavascriptEnabled, true);
    ui->webView->settings()->setAttribute(QWebSettings::JavascriptEnabled, true);
    ui->webView->settings()->setAttribute(QWebSettings::PluginsEnabled, true);
    

    try the following Url in QWebview for facebook sharing. you will notice the problem.

    http://www.facebook.com/sharer.php?u=http://www.google.com&t=SearchEngine

    Thanks



  • Bug is posted in Qt Bug Tracker
    Bug id: QTBUG-15725
    Tag: "QDesktop openUrl() does not reload the given URL if browser is already open in symbian"

    http://bugreports.qt.nokia.com/browse/QTBUG-15725



  • this works fine for me on desktop

    and it doesn't crash on my device, but no webpage opens too. I had already logged a bug for web page not opening on my device, not able to trace it now ...

    +1 vote for your reported bug



  • It opens web page well on my device Nokia 5230 5th edition, but when the facebook render on QWebView javascript probelm arises.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.