QNX and android Plugin in QtCreator 2.5.81



  • I tried to build the QtCreator 2.5.81 (2.6), but failed to build using 4.8.1(mingw/2008/2010) on windows, then i tried with vc2012, it was successful but when i tried to run QtCreator popup message shown me:
    [code]'..../lib/qtcreator/plugins/RIM/Qnx.dll' is not a valid Qt plugin
    [/code]

    for which i compiled, it is not working.
    somebody have any idea.



  • Hi, can you run depends.exe on that plugin please to see if all of the dependent libraries are found at runtime.

    Also please set the environment variable QT_DEBUG_PLUGINS=1 and then launch creator from the command line to get some feedback on what is going wrong with the plugin loading.



  • I did that also. in report it says IESHIMS.dll (IEFRAME.dll dependency) file not found, but this error is shown for all plugins and dlls loaded properly.



  • One more interesting thing is that all plugins are having (plugin name).lib file except android and QNX plugins.
    QmlProfiler is also not loading showing some error.......



  • Finally solved by searching and comparing files, i found that all plugins have Metadata from json file but android and qnx plugins doesn't have yhis line.
    so i added the line in Qnxplugin.h
    [code]
    Q_PLUGIN_METADATA(IID "org.qt-project.Qt.QtCreatorPlugin" FILE "Qnx.json")
    [/code]
    and modified the qnx.json as shown below

    [code]{
    "Vendor" : "Research In Motion",

    "Category" : "Device Support",

    "Description" : "Adds support for QNX to Qt Creator",

    "Url" : "http://www.rim.com"
    }[/code]

    where
    [code]"Category" : "Device Support",[/code]
    was the end line in qnx.json file.

    similarly for the Android plugin and both are now recognized as plugins in QtCreator 2.5.81.



  • So you built creator against Qt 5 then? The new plugin format is a Qt5 feature. You said in the original post that you used Qt 4.8.1. Can you clarify please? I'll file a bug here about the missing json stuff for when building with Qt5.



  • yeah initially tried with Qt5 only (failed for not invalid plugin), but after failure i tried with 4.8.1 this time not able to compile fully may be the different version.

    But yes i have compiled with:
    Windows 7, 32 bit
    Visual Express 2010 (and installed VS2010 SP1)
    VC2010 compiler patch (VC-Compiler-KB2519277) after installing VS2010 sp1
    Windows SDK 7.1 (and using SDK 7.1 command Prompt)
    Qt 5 Beta1 (MSVC2010)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.